blob: a081cb17a84fcc59101c71c68f7ca482bf36cc57 [file] [log] [blame]
Brad Bishop0a921262019-09-24 07:40:45 -04001DESCRIPTION = "Utilities to collect and visualise system statistics"
2HOMEPAGE = "http://www.i-scream.org/libstatgrab/"
3
4LICENSE = "GPL-2.0+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "ncurses"
8
9PACKAGES_prepend = "statgrab statgrab-dbg saidar saidar-dbg ${PN}-mrtg "
10
11# don't use the git tag unless docbooc2x is available to build the manpages
12SRC_URI = "https://github.com/libstatgrab/libstatgrab/releases/download/LIBSTATGRAB_0_92/libstatgrab-0.92.tar.gz \
13 "
14SRC_URI[md5sum] = "5362b2ddbec54b3901e7d70c22cda249"
15SRC_URI[sha256sum] = "5bf1906aff9ffc3eeacf32567270f4d819055d8386d98b9c8c05519012d5a196"
16
Andrew Geissler82c905d2020-04-13 13:39:40 -050017UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
18
Brad Bishop0a921262019-09-24 07:40:45 -040019# Perl5 is for tests only
20EXTRA_OECONF = "--without-perl5 --with-mnttab=/proc/mounts"
21
Brad Bishope42b3e32020-01-15 22:08:42 -050022# use with caution - default properties are configured to trace
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[log4cplus] = "--with-log4cplus,--without-log4cplus,log4cplus"
25PACKAGECONFIG[logging] = "--enable-logging,--disable-logging,"
26
Brad Bishop0a921262019-09-24 07:40:45 -040027inherit autotools pkgconfig
28
29FILES_statgrab = "${bindir}/statgrab"
30FILES_statgrab-dbg = "${bindir}/.debug/statgrab"
31FILES_saidar = "${bindir}/saidar"
32FILES_saidar-dbg = "${bindir}/.debug/saidar"
33FILES_${PN}-mrtg = "${bindir}/statgrab-make-mrtg-config ${bindir}/statgrab-make-mrtg-index"
34RDEPENDS_${PN}-mrtg_append = "perl statgrab"