blob: df71695a97d7594616824efe822b8f41b3cc508b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Self-hosting"
6DESCRIPTION = "Packages required to run the build system"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
Brad Bishop00e122a2019-10-05 11:10:57 -04008PACKAGE_ARCH = "${TUNE_PKGARCH}"
9
Brad Bishop6dbb3162019-11-25 09:41:34 -050010inherit packagegroup features_check
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011# rdepends on libx11-dev
12REQUIRED_DISTRO_FEATURES = "x11"
13
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014# rdepends on libgl
15REQUIRED_DISTRO_FEATURES += "opengl"
16
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017PACKAGES = "\
18 packagegroup-self-hosted \
19 packagegroup-self-hosted-debug \
20 packagegroup-self-hosted-sdk \
21 packagegroup-self-hosted-extended \
22 packagegroup-self-hosted-graphics \
23 packagegroup-self-hosted-host-tools \
24 "
25
Patrick Williams213cb262021-08-07 19:21:33 -050026RDEPENDS:packagegroup-self-hosted = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027 packagegroup-self-hosted-debug \
28 packagegroup-self-hosted-sdk \
29 packagegroup-self-hosted-extended \
30 packagegroup-self-hosted-graphics \
31 packagegroup-self-hosted-host-tools \
32 "
33
Patrick Williams213cb262021-08-07 19:21:33 -050034RDEPENDS:packagegroup-self-hosted-host-tools = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035 e2fsprogs \
36 e2fsprogs-e2fsck \
37 e2fsprogs-mke2fs \
38 e2fsprogs-tune2fs \
39 hdparm \
40 iptables \
Brad Bishop79641f22019-09-10 07:20:22 -040041 lsb-release \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042 mc \
Patrick Williamsb58112e2024-03-07 11:16:36 -060043 mc-shell \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050044 mc-helpers \
45 mc-helpers-perl \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050046 parted \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050047 ${PSEUDO} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048 screen \
49 "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050050PSEUDO = "pseudo"
Patrick Williams213cb262021-08-07 19:21:33 -050051PSEUDO:libc-musl = ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052
Patrick Williams213cb262021-08-07 19:21:33 -050053RRECOMMENDS:packagegroup-self-hosted-host-tools = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054 kernel-module-tun \
55 kernel-module-iptable-raw \
56 kernel-module-iptable-nat \
57 kernel-module-iptable-mangle \
58 kernel-module-iptable-filter \
59 "
60
Patrick Williams213cb262021-08-07 19:21:33 -050061RDEPENDS:packagegroup-self-hosted-sdk = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062 autoconf \
63 automake \
64 binutils \
65 binutils-symlinks \
66 ccache \
67 coreutils \
68 cpp \
69 cpp-symlinks \
70 distcc \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050071 file \
72 findutils \
73 g++ \
74 g++-symlinks \
75 gcc \
76 gcc-symlinks \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050077 ldd \
78 less \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050079 libstdc++ \
80 libstdc++-dev \
81 libtool \
82 make \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050083 perl-module-re \
84 perl-module-text-wrap \
85 pkgconfig \
86 quilt \
87 sed \
88 "
Patrick Williams213cb262021-08-07 19:21:33 -050089RDEPENDS:packagegroup-self-hosted-sdk:append:mingw32 = "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080090 libssp \
91 libssp-dev \
92 libssp-staticdev \
93 "
94# rpcsvc-proto: for rpcgen
Patrick Williams213cb262021-08-07 19:21:33 -050095RDEPENDS:packagegroup-self-hosted-sdk:append:libc-glibc = "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050096 glibc-gconv-ibm850 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050097 glibc-utils \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080098 rpcsvc-proto \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050099 "
Patrick Williams92b42cb2022-09-03 06:53:57 -0500100
101STRACE = "strace"
102STRACE:riscv32 = ""
Patrick Williams213cb262021-08-07 19:21:33 -0500103RDEPENDS:packagegroup-self-hosted-debug = " \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500104 gdb \
105 gdbserver \
106 rsync \
Patrick Williams92b42cb2022-09-03 06:53:57 -0500107 ${STRACE} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500108 tcf-agent"
109
110
Patrick Williams213cb262021-08-07 19:21:33 -0500111RDEPENDS:packagegroup-self-hosted-extended = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500112 bzip2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500113 chrpath \
114 cpio \
115 curl \
116 diffstat \
117 diffutils \
118 elfutils \
119 expat \
120 gawk \
121 gdbm \
122 gettext \
123 gettext-runtime \
124 git \
125 git-perltools \
126 grep \
127 groff \
128 gzip \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500129 libaio \
130 libusb1 \
131 libxml2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500132 lsof \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500133 man \
134 man-pages \
135 mdadm \
136 minicom \
137 mtools \
138 ncurses \
139 ncurses-terminfo-base \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500140 nfs-utils \
141 nfs-utils-client \
142 openssl \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500143 openssh-scp \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500144 openssh-sftp-server \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500145 openssh-ssh \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500146 opkg \
147 opkg-utils \
148 patch \
149 perl \
150 perl-dev \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500151 perl-misc \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500152 perl-modules \
153 perl-pod \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600154 python3 \
155 python3-modules \
156 python3-git \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500157 quota \
158 readline \
159 rpm \
160 setserial \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -0600161 settings-daemon \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500162 socat \
163 subversion \
164 sudo \
165 sysstat \
166 tar \
167 tcl \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500168 texinfo \
169 unzip \
170 usbutils \
171 watchdog \
172 wget \
173 which \
174 xinetd \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -0600175 xz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500176 zip \
177 zlib \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -0600178 zstd \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500179 "
180
181
Patrick Williams213cb262021-08-07 19:21:33 -0500182RDEPENDS:packagegroup-self-hosted-graphics = "\
Andrew Geissler6aa7eec2023-03-03 12:41:14 -0600183 adwaita-icon-theme \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500184 builder \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -0600185 l3afpad \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500186 libgl \
187 libgl-dev \
188 libglu \
189 libglu-dev \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500190 libx11-dev \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500191 pcmanfm \
192 vte \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -0600193 xdg-utils \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500194 "