blob: 79a06170e02ef5cfbb63cd0c7563cde4ae00518a [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Skip tests when modules not available"
2DESCRIPTION = "Skip test scripts if modules are not available. \
3The requested modules will be loaded, and optionally have their versions \
4checked. If the module is missing, the test script will be skipped. Modules \
5that are found but fail to compile will exit with an error rather than skip."
6
7HOMEPAGE = "https://metacpan.org/release/Test-Needs"
8SECTION = "libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010
11CPAN_NAME = "Test-Needs"
12CPAN_AUTHOR = "HAARG"
13
Brad Bishop393846f2019-05-20 12:24:11 -040014LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=88;endline=89"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015
16DEPENDS += "perl"
17
Brad Bishop393846f2019-05-20 12:24:11 -040018SRC_URI = "https://cpan.metacpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz"
Brad Bishop316dfdd2018-06-25 12:45:53 -040019
Patrick Williams864cc432023-02-09 14:54:44 -060020SRC_URI[sha256sum] = "923ffdc78fcba96609753e4bae26b0ba0186893de4a63cd5236e012c7c90e208"
Brad Bishop316dfdd2018-06-25 12:45:53 -040021
22S = "${WORKDIR}/${CPAN_NAME}-${PV}"
23
24inherit cpan ptest-perl
25
Patrick Williams213cb262021-08-07 19:21:33 -050026RDEPENDS:${PN}-ptest += "perl-module-test-more perl-module-ipc-open3 perl-module-lib perl-module-version"
Brad Bishop316dfdd2018-06-25 12:45:53 -040027
28BBCLASSEXTEND = "native"