blob: 13e2077ae4587cbc53d962b5c6debf7b82c20422 [file] [log] [blame]
Kuiying Wang91ff72a2018-11-08 16:52:49 +08001SUMMARY = "OpenBMC Buttons"
2DESCRIPTION = "OpenBMC All buttons"
Kuiying Wang91ff72a2018-11-08 16:52:49 +08003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Kuiying Wang91ff72a2018-11-08 16:52:49 +08005DEPENDS += " \
6 systemd \
7 sdbusplus \
8 phosphor-dbus-interfaces \
9 phosphor-logging \
Kuiying Wang91ff72a2018-11-08 16:52:49 +080010 "
Andrew Geissler4b490232023-02-15 10:00:25 -060011SRCREV = "4fcfadd3a947e42b12d738775e8ed60c8726d71d"
Ed Tanous9936f862022-09-19 09:13:20 -070012PACKAGECONFIG ??= "signals handler"
13PACKAGECONFIG[signals] = ",,gpioplus nlohmann-json,"
Naveen Mosesb7590f62022-08-30 03:38:12 +053014PACKAGECONFIG[handler] = ",,,${VIRTUAL-RUNTIME_obmc-host-state-manager} ${VIRTUAL-RUNTIME_obmc-chassis-state-manager}"
Ed Tanous9936f862022-09-19 09:13:20 -070015PV = "1.0+git${SRCPV}"
16PR = "r1"
17
18SRC_URI += "git://github.com/openbmc/phosphor-buttons.git;branch=master;protocol=https"
19
20S = "${WORKDIR}/git"
21SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
22SYSTEMD_SERVICE:${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service"
23SYSTEMD_SERVICE:${PN}-handler = "phosphor-button-handler.service"
24
25inherit meson pkgconfig systemd
26
27FILES:${PN}-signals = "${bindir}/buttons"
28FILES:${PN}-handler = "${bindir}/button-handler"
29
30ALLOW_EMPTY:${PN} = "1"
31
32BUTTON_PACKAGES = "${PN}-signals ${PN}-handler"
33
34PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"
Naveen Moses1ede6c12022-07-20 00:36:02 +053035
36do_install:append() {
37 if [ -e "${WORKDIR}/gpio_defs.json" ]; then
38 install -m 0755 -d ${D}/etc/default/obmc/gpio
39 install -m 0644 -D ${WORKDIR}/gpio_defs.json \
40 ${D}/etc/default/obmc/gpio
41 fi
42}