Matt Spinler | 1b8b904 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor machine readable workbook patching script" |
| 2 | DESCRIPTION = "Retrieve the script that can patch the MRW XML" |
Brad Bishop | edb390a | 2018-11-06 10:09:31 -0800 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 5 | DEPENDS += "python3-native python3-lxml-native" |
| 6 | SRCREV = "${MRW_TOOLS_SRCREV}" |
| 7 | PV = "1.0+git${SRCPV}" |
| 8 | PR = "r1" |
| 9 | |
| 10 | SRC_URI += "${MRW_TOOLS_SRC_URI}" |
Matt Spinler | 1b8b904 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
Matt Spinler | b103a33 | 2016-09-15 10:39:43 -0500 | [diff] [blame] | 14 | inherit mrw-rev |
Joseph Reynolds | 79809ea | 2021-02-26 15:37:31 -0600 | [diff] [blame] | 15 | inherit native |
Matt Spinler | 1b8b904 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 16 | |
Matt Spinler | 1b8b904 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 17 | do_install() { |
Matt Spinler | 98c33e3 | 2016-09-20 13:32:44 -0500 | [diff] [blame] | 18 | install -d ${D}${bindir}/obmc-mrw |
| 19 | install -m 0755 patchxml.py ${D}${bindir}/obmc-mrw |
Matt Spinler | 1b8b904 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 20 | } |