blob: 22d68814ee31655b23115fd132ca8c755edc55f6 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A graphical front-end for gcov"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05002HOMEPAGE = "https://github.com/linux-test-project/lcov"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \
4tool gcov. It collects gcov data for multiple source files and creates \
5HTML pages containing the source code annotated with coverage information. \
6It also adds overview pages for easy navigation within the file structure. \
Patrick Williamsddad1a12017-02-23 20:36:32 -06007LCOV supports statement, function and branch coverage measurement."
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "GPL-2.0-only"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
10
Patrick Williams213cb262021-08-07 19:21:33 -050011RDEPENDS:${PN} += " \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012 perl \
13 perl-module-filehandle \
14 perl-module-getopt-std \
Brad Bishop0e2770c2020-01-21 07:31:46 -050015 perl-module-digest-md5 \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016 perl-module-digest-sha \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 perl-module-constant \
18 perl-module-cwd \
19 perl-module-errno \
20 perl-module-file-basename \
Andrew Geissler82c905d2020-04-13 13:39:40 -050021 perl-module-file-copy \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022 perl-module-file-find \
23 perl-module-file-path \
24 perl-module-file-spec \
25 perl-module-file-spec-functions \
26 perl-module-file-spec-unix \
27 perl-module-file-temp \
28 perl-module-getopt-long \
29 perl-module-list-util \
30 perl-module-mro \
31 perl-module-overload \
32 perl-module-overloading \
33 perl-module-overload-numbers \
34 perl-module-parent \
35 perl-module-pod-usage \
36 perl-module-posix \
37 perl-module-re \
38 perl-module-safe \
39 perl-module-scalar-util \
40 perl-module-term-cap \
41 perl-module-text-parsewords \
42 perl-module-tie-hash \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050043"
44
Patrick Williams213cb262021-08-07 19:21:33 -050045RDEPENDS:${PN}:append:class-target = " \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050046 gcov \
47 gcov-symlinks \
48"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050049SRC_URI = "https://github.com/linux-test-project/lcov/releases/download/v${PV}/lcov-${PV}.tar.gz"
50SRC_URI[md5sum] = "bfee0cef50d7b7bd1df03bfadf68dcef"
51SRC_URI[sha256sum] = "987031ad5528c8a746d4b52b380bc1bffe412de1f2b9c2ba5224995668e3240b"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050052
53do_install() {
Patrick Williams8e7b46e2023-05-01 14:19:06 -050054 oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir} LCOV_PERL_PATH="/usr/bin/env perl"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050055}
56
Andrew Geissler82c905d2020-04-13 13:39:40 -050057BBCLASSEXTEND = "native nativesdk"