blob: f1bafc92af9e1012ce5639a63c8fc55309f7f0cc [file] [log] [blame]
Brad Bishop37653df2017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
6
7inherit autotools pkgconfig
8inherit pythonnative
9inherit obmc-phosphor-license
10inherit obmc-phosphor-dbus-service
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050011inherit phosphor-logging
Marri Devender Raobf369d02017-06-06 08:39:39 -050012inherit phosphor-dbus-yaml
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050013
14DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
15
16DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
18DEPENDS += "python-mako-native"
19DEPENDS += "python-pyyaml-native"
Patrick Williams845123d2016-12-09 08:56:38 -060020DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihalli0ac54522017-03-23 03:52:28 -050021DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050022DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Rao3b1e30e2017-05-14 09:01:35 -050023DEPENDS += "phosphor-logging-error-logs-native"
Deepak Kodihallid7963ee2017-06-13 12:52:19 -050024DEPENDS += "cereal"
Adriana Kobylak385287c2017-02-09 15:06:41 -060025RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050026PROVIDES += "virtual/obmc-logging-mgmt"
27RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
28
Michael Tritz026fbaf2017-03-13 14:54:24 -050029PACKAGE_BEFORE_PN = "${PN}-test"
30FILES_${PN}-test = "${bindir}/*-test"
31
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050032SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williams90de4182017-08-16 16:10:05 -050033SRCREV = "7656fba39d7bef754ee38a1d9a7889e7d3309db4"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050034
35S = "${WORKDIR}/git"
36
Deepak Kodihalli430a5062017-03-28 07:47:51 -050037PACKAGECONFIG ??= "metadata-processing"
38PACKAGECONFIG[metadata-processing] = " \
39 --enable-metadata-processing, \
40 --disable-metadata-processing, , \
41 "
42
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050043EXTRA_OECONF = " \
44 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
45 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
46 "