blob: dd3541096fd19098d6bdb9255ba9e91cb0dcbb0e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU cpio is a program to manage archives of files"
2DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \
3another. It handles a number of cpio formats as well as reading and writing tar files."
4HOMEPAGE = "http://www.gnu.org/software/cpio/"
5SECTION = "base"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-3.0-only"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
8
9SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
10 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050011 file://0002-src-global.c-Remove-superfluous-declaration-of-progr.patch \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050012 file://CVE-2021-38185.patch \
Patrick Williams91c40602023-06-15 05:43:17 -050013 file://0001-Wrong-CRC-with-ASCII-CRC-for-large-files.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050014 "
15
16SRC_URI[md5sum] = "389c5452d667c23b5eceb206f5000810"
17SRC_URI[sha256sum] = "e87470d9c984317f658567c03bfefb6b0c829ff17dbf6b0de48d71a4c8f3db88"
18
19inherit autotools gettext texinfo
20
William A. Kennington IIIac69b482021-06-02 12:28:27 -070021# Issue applies to use of cpio in SUSE/OBS, doesn't apply to us
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022CVE_CHECK_IGNORE += "CVE-2010-4226"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070023
Andrew Geissler82c905d2020-04-13 13:39:40 -050024EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
25
26do_install () {
27 autotools_do_install
28 if [ "${base_bindir}" != "${bindir}" ]; then
29 install -d ${D}${base_bindir}/
30 mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio"
Andrew Geissler475cb722020-07-10 16:00:51 -050031 if [ "${sbindir}" != "${bindir}" ]; then
32 rmdir ${D}${bindir}/
33 fi
Andrew Geissler82c905d2020-04-13 13:39:40 -050034 fi
35
36 # Avoid conflicts with the version from tar
37 mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8"
38}
39
40PACKAGES =+ "${PN}-rmt"
41
Patrick Williams213cb262021-08-07 19:21:33 -050042FILES:${PN}-rmt = "${sbindir}/rmt*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050043
44inherit update-alternatives
45
46ALTERNATIVE_PRIORITY = "100"
47
Patrick Williams213cb262021-08-07 19:21:33 -050048ALTERNATIVE:${PN} = "cpio"
49ALTERNATIVE:${PN}-rmt = "rmt"
Andrew Geissler82c905d2020-04-13 13:39:40 -050050
51ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
52
53ALTERNATIVE_PRIORITY[rmt] = "50"
54ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
55
Andrew Geissler475cb722020-07-10 16:00:51 -050056BBCLASSEXTEND = "native nativesdk"