blob: 0af956a8f0f0f7921c12bb7fe7db4a277cba3511 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
Brad Bishop19323692019-04-05 15:28:33 -04006LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler615f2f12022-07-15 14:00:58 -050011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
12 file://0001-fix-the-FPE-in-tiffcrop-415-427-and-428.patch"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013
Andrew Geissler78b72792022-06-14 06:47:25 -050014SRC_URI[sha256sum] = "917223b37538959aca3b790d2d73aa6e626b688e02dcda272aec24c2f498abed"
Brad Bishop19323692019-04-05 15:28:33 -040015
16# exclude betas
17UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
18
William A. Kennington IIIac69b482021-06-02 12:28:27 -070019# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
20# and 4.3.0 doesn't have the issue
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000021CVE_CHECK_IGNORE += "CVE-2015-7313"
Andrew Geissler78b72792022-06-14 06:47:25 -050022# These issues only affect libtiff post-4.3.0 but before 4.4.0,
23# caused by 3079627e and fixed by b4e79bfa.
24CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623"
25
26# Issue is in jbig which we don't enable
27CVE_CHECK_IGNORE += "CVE-2022-1210"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070028
Brad Bishop19323692019-04-05 15:28:33 -040029inherit autotools multilib_header
30
31CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
32
33PACKAGECONFIG ?= "cxx jpeg zlib lzma \
34 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
35
36PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
Andrew Geissler78b72792022-06-14 06:47:25 -050037PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
Brad Bishop19323692019-04-05 15:28:33 -040038PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
39PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
40PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
41
42# Convert single-strip uncompressed images to multiple strips of specified
43# size (default: 8192) to reduce memory usage
44PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
45
46# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
47PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
48
49# Control picking up YCbCr subsample info. Disable to support files lacking
50# the tag
51PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
52
53# Support a mechanism allowing reading large strips (usually one strip files)
54# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
55PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
56
57PACKAGES =+ "tiffxx tiff-utils"
Patrick Williams213cb262021-08-07 19:21:33 -050058FILES:tiffxx = "${libdir}/libtiffxx.so.*"
59FILES:tiff-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040060
Patrick Williams213cb262021-08-07 19:21:33 -050061do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040062 oe_multilib_header tiffconf.h
63}
64
Andrew Geissler4ed12e12020-06-05 18:00:41 -050065BBCLASSEXTEND = "native nativesdk"