blob: 00ff906dedd255f344b63f00747f1c3ec00471a4 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
9 file://testcases/network/can/filter-tests/COPYING;md5=5b155ea7d7f86eae8e8832955d8b70bc \
10"
11
12DEPENDS = "attr libaio libcap acl openssl zip-native"
13DEPENDS:append:libc-musl = " fts "
14EXTRA_OEMAKE:append:libc-musl = " LIBC=musl "
15EXTRA_OECONF:append:libc-musl = " LIBS=-lfts "
16
17# since ltp contains x86-64 assembler which uses the frame-pointer register,
18# set -fomit-frame-pointer x86-64 to handle cases where optimisation
19# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
20# earlier in CFLAGS, etc.
21CFLAGS:append:x86-64 = " -fomit-frame-pointer"
Andrew Geissler615f2f12022-07-15 14:00:58 -050022TUNE_CCARGS:remove:x86 = "-mfpmath=sse"
Patrick Williams92b42cb2022-09-03 06:53:57 -050023TUNE_CCARGS:remove:x86-64 = "-mfpmath=sse"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024
25CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
26CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Andrew Geissler78b72792022-06-14 06:47:25 -050027SRCREV = "6f88e0f6f1d6eb12c48c902f50f47ecbd3b0f18a"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000028
29SRC_URI = "git://github.com/linux-test-project/ltp.git;branch=master;protocol=https \
30 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000031 file://disable_hanging_tests.patch \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050032 file://0001-kvm-Fix-stack-access-mode-in-KVM-test-ELF-headers.patch \
33 file://0002-kvm-use-LD-instead-of-hardcoding-ld.patch \
34 file://0003-Add-KVM_LD-Makefile-variable-for-building-KVM-payloa.patch \
35 file://0001-nfs05_make_tree-Restore-5-min-timeout.patch \
36 file://0001-syscalls-migrate_pages03-restore-runtime-to-5m.patch \
37 file://0001-mountns0-1-3-wait-for-umount-completed-in-thread_b.patch \
38 file://0001-netstress-Restore-runtime-to-5m.patch \
39 file://0001-net_stress-Fix-usage-of-variables-from-tst_net.sh.patch \
40 file://0001-memcg-functional-Fix-usage-of-PAGESIZE-from-memcg_li.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050041 file://0001-lapi-pidfd-adding-pidfd-header-file.patch \
42 file://0001-lapi-fsmount-resolve-conflict-in-different-header-fi.patch \
43 file://0001-rt-migrate-Use-int-instead-of-pthread_t-for-thread-I.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000044 "
45
46S = "${WORKDIR}/git"
47
48inherit autotools-brokensep pkgconfig
49
Andrew Geissler78b72792022-06-14 06:47:25 -050050# Version 20220527 added KVM test infrastructure which currently fails to build with gold due to
51# SORT_NONE in linker script which isn't supported by gold:
52# https://sourceware.org/bugzilla/show_bug.cgi?id=18097
53# https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36
54LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"
55
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050056# After 0002-kvm-use-LD-instead-of-hardcoding-ld.patch
57# https://github.com/linux-test-project/ltp/commit/f94e0ef3b7280f886384703ef9019aaf2f2dfebb
58# it fails with gold also a bit later when trying to use *-payload.bin
59# http://errors.yoctoproject.org/Errors/Details/663094/
60# work around this by forcing .bfd linked in LD when ld-is-gold is in DISTRO_FEATURES
61KVM_LD = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '${HOST_PREFIX}ld.bfd${TOOLCHAIN_OPTIONS} ${HOST_LD_ARCH}', '${LD}', d)}"
62
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000063TARGET_CC_ARCH += "${LDFLAGS}"
64
65export prefix = "/opt/${PN}"
66export exec_prefix = "/opt/${PN}"
67
68PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
69EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
70EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
71# ltp network/rpc test cases ftbfs when libtirpc is found
72EXTRA_OECONF += " --without-tirpc "
73
74do_compile() {
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050075 oe_runmake HOSTCC="${CC_FOR_BUILD}" HOST_CFLAGS="${CFLAGS_FOR_BUILD}" HOST_LDFLAGS="${LDFLAGS_FOR_BUILD}" KVM_LD="${KVM_LD}"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000076}
77
78do_install(){
79 install -d ${D}${prefix}/
80 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
81
82 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
83 # as it lacks dependency on some perl moudle such as LWP::Simple
84 # And this script previously works as a tool for analyzing failures from LTP
85 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
86 # http://khack.osdl.org to retrieve ltp test results run on
87 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
88 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
89
90 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
91 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
92
93 # Makefile were configured in the build system
94 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
95 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
96 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
97 -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
98 -e 's@[^ ]*--sysroot=[^ "]*@@g'
99
100 # The controllers memcg_stree test seems to cause us hangs and takes 900s
101 # (maybe we expect more regular output?), anyhow, skip it
102 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler615f2f12022-07-15 14:00:58 -0500103
104 # We don't need to ship the compile logs that open_posix_testsuite writes
105 rm -f ${D}${prefix}/testcases/open_posix_testsuite/logfile.*
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000106}
107
108RDEPENDS:${PN} = "\
109 attr \
110 bash \
111 bc \
112 coreutils \
113 cpio \
114 cronie \
115 curl \
116 e2fsprogs \
117 e2fsprogs-mke2fs \
118 expect \
119 file \
120 gawk \
121 gdb \
122 gzip \
123 iproute2 \
124 ldd \
125 libaio \
126 logrotate \
127 net-tools \
128 perl \
129 python3-core \
130 procps \
131 quota \
132 unzip \
133 util-linux \
134 which \
135 tar \
136"
137
138FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
139
140# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
141INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
142INSANE_SKIP:${PN} += "already-stripped staticdev"
143
144remove_broken_musl_sources() {
145 [ "${TCLIBC}" = "musl" ] || return 0
146
147 cd ${S}
148 echo "WARNING: remove unsupported tests (until they're fixed)"
149
150 # sync with upstream
151 # https://github.com/linux-test-project/ltp/blob/master/ci/alpine.sh#L33
152 rm -rfv \
153 testcases/kernel/syscalls/confstr/confstr01.c \
154 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
155 testcases/kernel/syscalls/getcontext/getcontext01.c \
156 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
157 testcases/kernel/syscalls/timer_create/timer_create01.c \
158 testcases/kernel/syscalls/timer_create/timer_create03.c \
159 utils/benchmark/ebizzy-0.3
160}
161do_patch[postfuncs] += "remove_broken_musl_sources"
162
163# Avoid file dependency scans, as LTP checks for things that may or may not
164# exist on the running system. For instance it has specific checks for
165# csh and ksh which are not typically part of OpenEmbedded systems (but
166# can be added via additional layers.)
167SKIP_FILEDEPS:${PN} = '1'