blob: 46d706b955f6921776d99ef86c172142dd132f6e [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Linux kernel Development Source"
2DESCRIPTION = "Development source linux kernel. When built, this recipe packages the \
3source of the preferred virtual/kernel provider and makes it available for full kernel \
4development or external module builds"
5
6SECTION = "kernel"
7
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "GPL-2.0-only"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10inherit linux-kernel-base
11
12# Whilst not a module, this ensures we don't get multilib extended (which would make no sense)
13inherit module-base
14
15# We need the kernel to be staged (unpacked, patched and configured) before
16# we can grab the source and make the source package. We also need the bits from
17# ${B} not to change while we install, so virtual/kernel must finish do_compile.
18do_install[depends] += "virtual/kernel:do_shared_workdir"
19# Need the source, not just the output of populate_sysroot
20do_install[depends] += "virtual/kernel:do_install"
21
22# There's nothing to do here, except install the source where we can package it
23do_fetch[noexec] = "1"
24do_unpack[noexec] = "1"
25do_patch[noexec] = "1"
26do_configure[noexec] = "1"
27do_compile[noexec] = "1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028deltask do_populate_sysroot
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030S = "${STAGING_KERNEL_DIR}"
31B = "${STAGING_KERNEL_BUILDDIR}"
32
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033PACKAGE_ARCH = "${MACHINE_ARCH}"
34
Brad Bishop19323692019-04-05 15:28:33 -040035KERNEL_BUILD_ROOT="${nonarch_base_libdir}/modules/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037do_install() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038 kerneldir=${D}${KERNEL_BUILD_ROOT}${KERNEL_VERSION}
39 install -d $kerneldir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041 # create the directory structure
42 rm -f $kerneldir/build
43 rm -f $kerneldir/source
44 mkdir -p $kerneldir/build
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080046 # for compatibility with some older variants of this package, we
47 # create a /usr/src/kernel symlink to /lib/modules/<version>/source
48 mkdir -p ${D}/usr/src
49 (
50 cd ${D}/usr/src
Andrew Geissler595f6302022-01-24 19:11:47 +000051 ln -rs ${D}${KERNEL_BUILD_ROOT}${KERNEL_VERSION}/source kernel
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052 )
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054 # for on target purposes, we unify build and source
55 (
56 cd $kerneldir
57 ln -s build source
58 )
Patrick Williamsc124f4f2015-09-15 14:41:29 -050059
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060 # first copy everything
61 (
62 cd ${S}
63 cp --parents $(find -type f -name "Makefile*" -o -name "Kconfig*") $kerneldir/build
64 cp --parents $(find -type f -name "Build" -o -name "Build.include") $kerneldir/build
65 )
Brad Bishop316dfdd2018-06-25 12:45:53 -040066
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080067 # then drop all but the needed Makefiles/Kconfig files
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080068 rm -rf $kerneldir/build/scripts
69 rm -rf $kerneldir/build/include
70
71 # now copy in parts from the build that we'll need later
72 (
73 cd ${B}
74
Andrew Geissler9aee5002022-03-30 16:27:02 +000075 if [ -s Module.symvers ]; then
76 cp Module.symvers $kerneldir/build
77 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080078 cp System.map* $kerneldir/build
79 if [ -s Module.markers ]; then
80 cp Module.markers $kerneldir/build
81 fi
82
Andrew Geissler82c905d2020-04-13 13:39:40 -050083 cp -a .config $kerneldir/build
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080084
85 # This scripts copy blow up QA, so for now, we require a more
86 # complex 'make scripts' to restore these, versus copying them
87 # here. Left as a reference to indicate that we know the scripts must
88 # be dealt with.
89 # cp -a scripts $kerneldir/build
90
Andrew Geissler6ce62a22020-11-30 19:58:47 -060091 # although module.lds can be regenerated on target via 'make modules_prepare'
92 # there are several places where 'makes scripts prepare' is done, and that won't
93 # regenerate the file. So we copy it onto the target as a migration to using
94 # modules_prepare
95 cp -a --parents scripts/module.lds $kerneldir/build/ 2>/dev/null || :
96
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080097 if [ -d arch/${ARCH}/scripts ]; then
98 cp -a arch/${ARCH}/scripts $kerneldir/build/arch/${ARCH}
99 fi
100 if [ -f arch/${ARCH}/*lds ]; then
101 cp -a arch/${ARCH}/*lds $kerneldir/build/arch/${ARCH}
102 fi
103
104 rm -f $kerneldir/build/scripts/*.o
105 rm -f $kerneldir/build/scripts/*/*.o
106
107 if [ "${ARCH}" = "powerpc" ]; then
108 if [ -e arch/powerpc/lib/crtsavres.S ] ||
109 [ -e arch/powerpc/lib/crtsavres.o ]; then
110 cp -a --parents arch/powerpc/lib/crtsavres.[So] $kerneldir/build/
111 fi
112 fi
113
Andrew Geissler595f6302022-01-24 19:11:47 +0000114 if [ "${ARCH}" = "arm64" -o "${ARCH}" = "riscv" ]; then
Patrick Williams03907ee2022-05-01 06:28:52 -0500115 if [ -e arch/${ARCH}/kernel/vdso/vdso.lds ]; then
116 cp -a --parents arch/${ARCH}/kernel/vdso/vdso.lds $kerneldir/build/
117 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800118 fi
Andrew Geissler5f350902021-07-23 13:09:54 -0400119 if [ "${ARCH}" = "powerpc" ]; then
120 cp -a --parents arch/powerpc/kernel/vdso32/vdso32.lds $kerneldir/build 2>/dev/null || :
121 cp -a --parents arch/powerpc/kernel/vdso64/vdso64.lds $kerneldir/build 2>/dev/null || :
Patrick Williams92b42cb2022-09-03 06:53:57 -0500122 # v5.19+
123 cp -a --parents arch/powerpc/kernel/vdso/vdso*.lds $kerneldir/build 2>/dev/null || :
Andrew Geissler5f350902021-07-23 13:09:54 -0400124 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800125
126 cp -a include $kerneldir/build/include
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500127
128 # we don't usually copy generated files, since they can be rebuilt on the target,
129 # but without this file, we get a forced syncconfig run in v5.8+, which prompts and
130 # breaks workflows.
131 cp -a --parents include/generated/autoconf.h $kerneldir/build 2>/dev/null || :
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600132
Andrew Geissler615f2f12022-07-15 14:00:58 -0500133 if [ -e $kerneldir/include/generated/.vdso-offsets.h.cmd ] ||
134 [ -e $kerneldir/build/include/generated/.vdso-offsets.h.cmd ] ||
135 [ -e $kerneldir/build/include/generated/.vdso32-offsets.h.cmd ] ; then
136 rm -f $kerneldir/include/generated/.vdso-offsets.h.cmd
137 rm -f $kerneldir/build/include/generated/.vdso-offsets.h.cmd
138 rm -f $kerneldir/build/include/generated/.vdso32-offsets.h.cmd
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600139 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800140 )
141
142 # now grab the chunks from the source tree that we need
143 (
144 cd ${S}
145
146 cp -a scripts $kerneldir/build
147
148 # if our build dir had objtool, it will also be rebuilt on target, so
149 # we copy what is required for that build
150 if [ -f ${B}/tools/objtool/objtool ]; then
151 # these are a few files associated with objtool, since we'll need to
152 # rebuild it
153 cp -a --parents tools/build/Build.include $kerneldir/build/
154 cp -a --parents tools/build/Build $kerneldir/build/
155 cp -a --parents tools/build/fixdep.c $kerneldir/build/
156 cp -a --parents tools/scripts/utilities.mak $kerneldir/build/
157
158 # extra files, just in case
159 cp -a --parents tools/objtool/* $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500160 cp -a --parents tools/lib/* $kerneldir/build/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800161 cp -a --parents tools/lib/subcmd/* $kerneldir/build/
162
163 cp -a --parents tools/include/* $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500164
165 cp -a --parents $(find tools/arch/${ARCH}/ -type f) $kerneldir/build/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800166 fi
167
168 if [ "${ARCH}" = "arm64" ]; then
169 # arch/arm64/include/asm/xen references arch/arm
170 cp -a --parents arch/arm/include/asm/xen $kerneldir/build/
171 # arch/arm64/include/asm/opcodes.h references arch/arm
172 cp -a --parents arch/arm/include/asm/opcodes.h $kerneldir/build/
173
Brad Bishop79641f22019-09-10 07:20:22 -0400174 cp -a --parents arch/arm64/kernel/vdso/*gettimeofday.* $kerneldir/build/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800175 cp -a --parents arch/arm64/kernel/vdso/sigreturn.S $kerneldir/build/
176 cp -a --parents arch/arm64/kernel/vdso/note.S $kerneldir/build/
177 cp -a --parents arch/arm64/kernel/vdso/gen_vdso_offsets.sh $kerneldir/build/
178
Andrew Geissler82c905d2020-04-13 13:39:40 -0500179 cp -a --parents arch/arm64/kernel/module.lds $kerneldir/build/ 2>/dev/null || :
Andrew Geissler5f350902021-07-23 13:09:54 -0400180
181 # 5.13+ needs these tools
182 cp -a --parents arch/arm64/tools/gen-cpucaps.awk $kerneldir/build/ 2>/dev/null || :
183 cp -a --parents arch/arm64/tools/cpucaps $kerneldir/build/ 2>/dev/null || :
184
Patrick Williams92b42cb2022-09-03 06:53:57 -0500185 # 5.19+
186 cp -a --parents arch/arm64/tools/gen-sysreg.awk $kerneldir/build/ 2>/dev/null || :
187 cp -a --parents arch/arm64/tools/sysreg $kerneldir/build/ 2>/dev/null || :
188
Andrew Geissler5f350902021-07-23 13:09:54 -0400189 if [ -e $kerneldir/build/arch/arm64/tools/gen-cpucaps.awk ]; then
190 sed -i -e "s,#!.*awk.*,#!${USRBINPATH}/env awk," $kerneldir/build/arch/arm64/tools/gen-cpucaps.awk
191 fi
Patrick Williams92b42cb2022-09-03 06:53:57 -0500192 if [ -e $kerneldir/build/arch/arm64/tools/gen-sysreg.awk ]; then
193 sed -i -e "s,#!.*awk.*,#!${USRBINPATH}/env awk," $kerneldir/build/arch/arm64/tools/gen-sysreg.awk
194 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800195 fi
196
Brad Bishop19323692019-04-05 15:28:33 -0400197 if [ "${ARCH}" = "powerpc" ]; then
198 # 5.0 needs these files, but don't error if they aren't present in the source
199 cp -a --parents arch/${ARCH}/kernel/syscalls/syscall.tbl $kerneldir/build/ 2>/dev/null || :
200 cp -a --parents arch/${ARCH}/kernel/syscalls/syscalltbl.sh $kerneldir/build/ 2>/dev/null || :
201 cp -a --parents arch/${ARCH}/kernel/syscalls/syscallhdr.sh $kerneldir/build/ 2>/dev/null || :
Andrew Geissler5f350902021-07-23 13:09:54 -0400202 cp -a --parents arch/${ARCH}/kernel/vdso32/* $kerneldir/build/ 2>/dev/null || :
203 cp -a --parents arch/${ARCH}/kernel/vdso64/* $kerneldir/build/ 2>/dev/null || :
Patrick Williams92b42cb2022-09-03 06:53:57 -0500204
205 # v5.19+
206 cp -a --parents arch/powerpc/kernel/vdso/*.S $kerneldir/build 2>/dev/null || :
207 cp -a --parents arch/powerpc/kernel/vdso/*gettimeofday.* $kerneldir/build 2>/dev/null || :
208 cp -a --parents arch/powerpc/kernel/vdso/gen_vdso*_offsets.sh $kerneldir/build/ 2>/dev/null || :
Brad Bishop19323692019-04-05 15:28:33 -0400209 fi
Andrew Geissler595f6302022-01-24 19:11:47 +0000210 if [ "${ARCH}" = "riscv" ]; then
211 cp -a --parents arch/riscv/kernel/vdso/*gettimeofday.* $kerneldir/build/
212 cp -a --parents arch/riscv/kernel/vdso/note.S $kerneldir/build/
Patrick Williams03907ee2022-05-01 06:28:52 -0500213 if [ -e arch/riscv/kernel/vdso/gen_vdso_offsets.sh ]; then
214 cp -a --parents arch/riscv/kernel/vdso/gen_vdso_offsets.sh $kerneldir/build/
215 fi
Andrew Geissler595f6302022-01-24 19:11:47 +0000216 cp -a --parents arch/riscv/kernel/vdso/* $kerneldir/build/ 2>/dev/null || :
217 fi
Brad Bishop19323692019-04-05 15:28:33 -0400218
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800219 # include the machine specific headers for ARM variants, if available.
220 if [ "${ARCH}" = "arm" ]; then
221 cp -a --parents arch/${ARCH}/mach-*/include $kerneldir/build/
222
223 # include a few files for 'make prepare'
224 cp -a --parents arch/arm/tools/gen-mach-types $kerneldir/build/
225 cp -a --parents arch/arm/tools/mach-types $kerneldir/build/
Brad Bishop19323692019-04-05 15:28:33 -0400226
Patrick Williams92b42cb2022-09-03 06:53:57 -0500227 # 5.19+
228 cp -a --parents arch/arm/tools/gen-sysreg.awk $kerneldir/build/ 2>/dev/null || :
229
Brad Bishop19323692019-04-05 15:28:33 -0400230 # ARM syscall table tools only exist for kernels v4.10 or later
231 SYSCALL_TOOLS=$(find arch/arm/tools -name "syscall*")
232 if [ -n "$SYSCALL_TOOLS" ] ; then
233 cp -a --parents $SYSCALL_TOOLS $kerneldir/build/
234 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800235
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600236 cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800237 fi
238
239 if [ -d arch/${ARCH}/include ]; then
240 cp -a --parents arch/${ARCH}/include $kerneldir/build/
241 fi
242
243 cp -a include $kerneldir/build
244
Brad Bishop79641f22019-09-10 07:20:22 -0400245 cp -a --parents lib/vdso/* $kerneldir/build/ 2>/dev/null || :
246
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800247 cp -a --parents tools/include/tools/le_byteshift.h $kerneldir/build/
248 cp -a --parents tools/include/tools/be_byteshift.h $kerneldir/build/
249
250 # required for generate missing syscalls prepare phase
Andrew Geissler82c905d2020-04-13 13:39:40 -0500251 cp -a --parents $(find arch/x86 -type f -name "syscall_32.tbl") $kerneldir/build
252 cp -a --parents $(find arch/arm -type f -name "*.tbl") $kerneldir/build 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800253
254 if [ "${ARCH}" = "x86" ]; then
255 # files for 'make prepare' to succeed with kernel-devel
Andrew Geisslerd159c7f2021-09-02 21:05:58 -0500256 cp -a --parents $(find arch/x86 -type f -name "syscall_32.tbl") $kerneldir/build/ 2>/dev/null || :
257 cp -a --parents $(find arch/x86 -type f -name "syscalltbl.sh") $kerneldir/build/ 2>/dev/null || :
258 cp -a --parents $(find arch/x86 -type f -name "syscallhdr.sh") $kerneldir/build/ 2>/dev/null || :
259 cp -a --parents $(find arch/x86 -type f -name "syscall_64.tbl") $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800260 cp -a --parents arch/x86/tools/relocs_32.c $kerneldir/build/
261 cp -a --parents arch/x86/tools/relocs_64.c $kerneldir/build/
262 cp -a --parents arch/x86/tools/relocs.c $kerneldir/build/
263 cp -a --parents arch/x86/tools/relocs_common.c $kerneldir/build/
264 cp -a --parents arch/x86/tools/relocs.h $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500265 cp -a --parents arch/x86/tools/gen-insn-attr-x86.awk $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800266 cp -a --parents arch/x86/purgatory/purgatory.c $kerneldir/build/
267
268 # 4.18 + have unified the purgatory files, so we ignore any errors if
269 # these files are not present
270 cp -a --parents arch/x86/purgatory/sha256.h $kerneldir/build/ 2>/dev/null || :
271 cp -a --parents arch/x86/purgatory/sha256.c $kerneldir/build/ 2>/dev/null || :
272
273 cp -a --parents arch/x86/purgatory/stack.S $kerneldir/build/
Brad Bishopc68388fc2019-08-26 01:33:31 -0400274 cp -a --parents arch/x86/purgatory/string.c $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800275 cp -a --parents arch/x86/purgatory/setup-x86_64.S $kerneldir/build/
276 cp -a --parents arch/x86/purgatory/entry64.S $kerneldir/build/
277 cp -a --parents arch/x86/boot/string.h $kerneldir/build/
278 cp -a --parents arch/x86/boot/string.c $kerneldir/build/
Brad Bishopc68388fc2019-08-26 01:33:31 -0400279 cp -a --parents arch/x86/boot/compressed/string.c $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800280 cp -a --parents arch/x86/boot/ctype.h $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500281
282 # objtool requires these files
283 cp -a --parents arch/x86/lib/inat.c $kerneldir/build/ 2>/dev/null || :
284 cp -a --parents arch/x86/lib/insn.c $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800285 fi
286
287 if [ "${ARCH}" = "mips" ]; then
288 cp -a --parents arch/mips/Kbuild.platforms $kerneldir/build/
289 cp --parents $(find -type f -name "Platform") $kerneldir/build
290 cp --parents arch/mips/boot/tools/relocs* $kerneldir/build
291 cp -a --parents arch/mips/kernel/asm-offsets.c $kerneldir/build
292 cp -a --parents kernel/time/timeconst.bc $kerneldir/build
293 cp -a --parents kernel/bounds.c $kerneldir/build
294 cp -a --parents Kbuild $kerneldir/build
Brad Bishop19323692019-04-05 15:28:33 -0400295 cp -a --parents arch/mips/kernel/syscalls/*.sh $kerneldir/build 2>/dev/null || :
296 cp -a --parents arch/mips/kernel/syscalls/*.tbl $kerneldir/build 2>/dev/null || :
297 cp -a --parents arch/mips/tools/elf-entry.c $kerneldir/build 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800298 fi
299
300 # required to build scripts/selinux/genheaders/genheaders
301 cp -a --parents security/selinux/include/* $kerneldir/build/
Brad Bishopc342db32019-05-15 21:57:59 -0400302
303 # copy any localversion files
304 cp -a localversion* $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800305 )
306
307 # Make sure the Makefile and version.h have a matching timestamp so that
308 # external modules can be built
309 touch -r $kerneldir/build/Makefile $kerneldir/build/include/generated/uapi/linux/version.h
310
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500311 # make sure these are at least as old as the .config, or rebuilds will trigger
312 touch -r $kerneldir/build/.config $kerneldir/build/include/generated/autoconf.h 2>/dev/null || :
313 touch -r $kerneldir/build/.config $kerneldir/build/include/config/auto.conf* 2>/dev/null || :
314
315 if [ -e "$kerneldir/build/include/config/auto.conf.cmd" ]; then
Andrew Geissler635e0e42020-08-21 15:58:33 -0500316 sed -i 's/ifneq "$(CC)" ".*-linux-.*gcc.*$/ifneq "$(CC)" "gcc"/' "$kerneldir/build/include/config/auto.conf.cmd"
317 sed -i 's/ifneq "$(LD)" ".*-linux-.*ld.bfd.*$/ifneq "$(LD)" "ld"/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500318 sed -i 's/ifneq "$(AR)" ".*-linux-.*ar.*$/ifneq "$(AR)" "ar"/' "$kerneldir/build/include/config/auto.conf.cmd"
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700319 sed -i 's/ifneq "$(OBJCOPY)" ".*-linux-.*objcopy.*$/ifneq "$(OBJCOPY)" "objcopy"/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geissler5f350902021-07-23 13:09:54 -0400320 if [ "${ARCH}" = "powerpc" ]; then
321 sed -i 's/ifneq "$(NM)" ".*-linux-.*nm.*$/ifneq "$(NM)" "nm --synthetic"/' "$kerneldir/build/include/config/auto.conf.cmd"
322 else
323 sed -i 's/ifneq "$(NM)" ".*-linux-.*nm.*$/ifneq "$(NM)" "nm"/' "$kerneldir/build/include/config/auto.conf.cmd"
324 fi
Andrew Geisslerc9f78652020-09-18 14:11:35 -0500325 sed -i 's/ifneq "$(HOSTCXX)" ".*$/ifneq "$(HOSTCXX)" "g++"/' "$kerneldir/build/include/config/auto.conf.cmd"
326 sed -i 's/ifneq "$(HOSTCC)" ".*$/ifneq "$(HOSTCC)" "gcc"/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500327 sed -i 's/ifneq "$(CC_VERSION_TEXT)".*\(gcc.*\)"/ifneq "$(CC_VERSION_TEXT)" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
328 sed -i 's/ifneq "$(srctree)" ".*"/ifneq "$(srctree)" "."/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geissler635e0e42020-08-21 15:58:33 -0500329 # we don't build against the defconfig, so make sure it isn't the trigger for syncconfig
330 sed -i 's/ifneq "$(KBUILD_DEFCONFIG)".*"\(.*\)"/ifneq "\1" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500331 fi
332
Brad Bishop79641f22019-09-10 07:20:22 -0400333 # make the scripts python3 safe. We won't be running these, and if they are
334 # left as /usr/bin/python rootfs assembly will fail, since we only have python3
335 # in the RDEPENDS (and the python3 package does not include /usr/bin/python)
336 for ss in $(find $kerneldir/build/scripts -type f -name '*'); do
337 sed -i 's,/usr/bin/python2,/usr/bin/env python3,' "$ss"
338 sed -i 's,/usr/bin/env python2,/usr/bin/env python3,' "$ss"
339 sed -i 's,/usr/bin/python,/usr/bin/env python3,' "$ss"
340 done
341
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800342 chown -R root:root ${D}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500343}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800344
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500345# Ensure we don't race against "make scripts" during cpio
346do_install[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
347
Patrick Williams213cb262021-08-07 19:21:33 -0500348FILES:${PN} = "${KERNEL_BUILD_ROOT} ${KERNEL_SRC_PATH}"
349FILES:${PN}-dbg += "${KERNEL_BUILD_ROOT}*/build/scripts/*/.debug/*"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800350
Patrick Williams213cb262021-08-07 19:21:33 -0500351RDEPENDS:${PN} = "bc python3 flex bison ${TCLIBC}-utils"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800352# 4.15+ needs these next two RDEPENDS
Patrick Williams213cb262021-08-07 19:21:33 -0500353RDEPENDS:${PN} += "openssl-dev util-linux"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800354# and x86 needs a bit more for 4.15+
Andrew Geisslerd159c7f2021-09-02 21:05:58 -0500355RDEPENDS:${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-dev', '', d)}"
Andrew Geissler635e0e42020-08-21 15:58:33 -0500356# 5.8+ needs gcc-plugins libmpc-dev
Patrick Williams213cb262021-08-07 19:21:33 -0500357RDEPENDS:${PN} += "gcc-plugins libmpc-dev"
Andrew Geissler5f350902021-07-23 13:09:54 -0400358# 5.13+ needs awk for arm64
Patrick Williams213cb262021-08-07 19:21:33 -0500359RDEPENDS:${PN}:append:aarch64 = " gawk"
Andrew Geissler5f350902021-07-23 13:09:54 -0400360# 5.13+ needs grep for powerpc
Patrick Williams213cb262021-08-07 19:21:33 -0500361RDEPENDS:${PN}:append:powerpc = " grep"