blob: 9348b7330ff8194bbd0f1505896a85213d933452 [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001OBMC_IMAGE_EXTRA_INSTALL:append:ibm-ac-server = " mboxd max31785-msl phosphor-msl-verify liberation-fonts uart-render-controller first-boot-set-hostname"
Andrew Geissler0c3e5ee2021-12-17 19:30:02 +00002OBMC_IMAGE_EXTRA_INSTALL:append:p10bmc = " mboxd"
Adriana Kobylakb96c7502021-08-06 16:25:30 +00003OBMC_IMAGE_EXTRA_INSTALL:append:mihawk = " mboxd liberation-fonts uart-render-controller "
Andrew Geisslerd1b5b202021-01-04 12:16:39 -06004
Patrick Williamsc0201c92022-04-18 14:29:31 -05005IMAGE_FEATURES:append = " obmc-dbus-monitor"
6
Andrew Geisslerd1b5b202021-01-04 12:16:39 -06007# remove so things fit in available flash space
Adriana Kobylakb96c7502021-08-06 16:25:30 +00008IMAGE_FEATURES:remove:witherspoon = "obmc-user-mgmt-ldap"
Andrew Geissler3475f832021-08-12 09:09:41 -04009IMAGE_FEATURES:remove:witherspoon = "obmc-telemetry"
Joseph Reynolds68e567f2021-02-24 17:20:01 -060010
Andrew Geissler0f80cda2021-08-31 15:50:20 -050011# Generic IPMI FRU vpd collection not needed on p10bmc
12IMAGE_FEATURES:remove:p10bmc = "obmc-fru-ipmi"
13
Joseph Reynolds68e567f2021-02-24 17:20:01 -060014# Optionally configure IBM service accounts
15#
16# To configure your distro, add the following line to its config:
17# DISTRO_FEATURES += "ibm-service-account-policy"
18#
19# The service account policy is as follows:
20# root - The root account remains present. It is needed for internal
21# accounting purposes and for debugging service access.
22# admin - Provides administrative control over the BMC. The role is
23# SystemAdministrator. Admin users have access to interfaces including:
24# Redfish, REST APIs, Web. No access to the BMC via: the BMC's physical
25# console, SSH to the BMC's command line.
26# IPMI access is not granted by default, but admins can authorize
27# themselves and enable the IPMI service.
28# The admin has access to the host console: ssh -p2200 admin@${bmc}.
29# The admin account does not have a home directory.
30# service - Provides IBM service and support representatives (SSRs, formerly
31# known as customer engineers or CEs) access to the BMC. The role is
32# OemIBMServiceAgent. The service user has full admin access, plus access
33# to BMC interfaces intended only to service the BMC and host, including
34# SSH access to the BMC's command line.
35# The service account is not authorized to IPMI because of the inherent
36# security weakness in the IPMI spec and also because the IPMI
37# implementation was not enhanced to use the ACF support.
38# The service account does not have a home directory. The home directory is
39# set to / (the root directory) to allow dropbear ssh connections.
40
Joseph Reynolds516363e2021-08-04 10:01:42 -050041# Override defaults from meta-phosphor/conf/distro/include/phosphor-defaults.inc
Joseph Reynolds68e567f2021-02-24 17:20:01 -060042
Joseph Reynolds68e567f2021-02-24 17:20:01 -060043#IBM_EXTRA_USERS_PARAMS += " \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050044# usermod -p ${DEFAULT_OPENBMC_PASSWORD} root; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060045# "
46
47# Add group "wheel" (before adding the "service" account).
48IBM_EXTRA_USERS_PARAMS += " \
49 groupadd wheel; \
50 "
51
52# Add the "admin" account.
53IBM_EXTRA_USERS_PARAMS += " \
54 useradd -M -d / --groups priv-admin,redfish,web -s /sbin/nologin admin; \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050055 usermod -p ${DEFAULT_OPENBMC_PASSWORD} admin; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060056 "
57
58# Add the "service" account.
59IBM_EXTRA_USERS_PARAMS += " \
60 useradd -M -d / --groups priv-admin,redfish,web,wheel service; \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050061 usermod -p ${DEFAULT_OPENBMC_PASSWORD} service; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060062 "
63
64# This is recipe specific to ensure it takes effect.
Adriana Kobylakb96c7502021-08-06 16:25:30 +000065EXTRA_USERS_PARAMS:pn-obmc-phosphor-image += "${@bb.utils.contains('DISTRO_FEATURES', 'ibm-service-account-policy', "${IBM_EXTRA_USERS_PARAMS}", '', d)}"
Joseph Reynolds68e567f2021-02-24 17:20:01 -060066
67# The service account needs sudo.
Adriana Kobylakb96c7502021-08-06 16:25:30 +000068IMAGE_INSTALL:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ibm-service-account-policy', 'sudo', '', d)}"