blob: df564f5354500613d4ae256c2313293870a05a27 [file] [log] [blame]
Kuiying Wang91ff72a2018-11-08 16:52:49 +08001SUMMARY = "OpenBMC Buttons"
2DESCRIPTION = "OpenBMC All buttons"
Kuiying Wang91ff72a2018-11-08 16:52:49 +08003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Kuiying Wang91ff72a2018-11-08 16:52:49 +08005DEPENDS += " \
6 systemd \
7 sdbusplus \
Matt Spinler49724a12023-04-05 19:07:58 +00008 sdeventplus \
Kuiying Wang91ff72a2018-11-08 16:52:49 +08009 phosphor-dbus-interfaces \
10 phosphor-logging \
Kuiying Wang91ff72a2018-11-08 16:52:49 +080011 "
Andrew Geissler942f3082024-02-27 09:50:16 -060012SRCREV = "3610608ce00dd68a08929a48931835ae375d51f9"
Ed Tanous9936f862022-09-19 09:13:20 -070013PACKAGECONFIG ??= "signals handler"
14PACKAGECONFIG[signals] = ",,gpioplus nlohmann-json,"
Naveen Mosesb7590f62022-08-30 03:38:12 +053015PACKAGECONFIG[handler] = ",,,${VIRTUAL-RUNTIME_obmc-host-state-manager} ${VIRTUAL-RUNTIME_obmc-chassis-state-manager}"
Ed Tanous9936f862022-09-19 09:13:20 -070016PV = "1.0+git${SRCPV}"
17PR = "r1"
18
Patrick Williamsbccaff32023-04-14 11:24:47 -050019SRC_URI = "git://github.com/openbmc/phosphor-buttons.git;branch=master;protocol=https"
Ed Tanous9936f862022-09-19 09:13:20 -070020
21S = "${WORKDIR}/git"
22SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
23SYSTEMD_SERVICE:${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service"
24SYSTEMD_SERVICE:${PN}-handler = "phosphor-button-handler.service"
25
26inherit meson pkgconfig systemd
27
28FILES:${PN}-signals = "${bindir}/buttons"
29FILES:${PN}-handler = "${bindir}/button-handler"
30
31ALLOW_EMPTY:${PN} = "1"
32
33BUTTON_PACKAGES = "${PN}-signals ${PN}-handler"
34
35PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"
Naveen Moses1ede6c12022-07-20 00:36:02 +053036
37do_install:append() {
38 if [ -e "${WORKDIR}/gpio_defs.json" ]; then
39 install -m 0755 -d ${D}/etc/default/obmc/gpio
40 install -m 0644 -D ${WORKDIR}/gpio_defs.json \
41 ${D}/etc/default/obmc/gpio
42 fi
Patrick Williamsbccaff32023-04-14 11:24:47 -050043}