blob: abc00a09ea0a4cec74ea0fef28badf0965d93fdb [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
Brad Bishopf3fd2882019-06-21 08:06:37 -040011SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \
12 file://0001-Fix-security-framework-bypass.patch \
Brad Bishop96ff1982019-08-19 13:50:42 -040013 file://CVE-2019-13117.patch \
14 file://CVE-2019-13118.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040015"
Brad Bishop19323692019-04-05 15:28:33 -040016
17SRC_URI[md5sum] = "b3bd254a03e46d58f8ad1e4559cd2c2f"
18SRC_URI[sha256sum] = "8e36605144409df979cab43d835002f63988f3dc94d5d3537c12796db90e38c8"
19
20UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
21
22S = "${WORKDIR}/libxslt-${PV}"
23
24BINCONFIG = "${bindir}/xslt-config"
25
26inherit autotools pkgconfig binconfig-disabled lib_package
27
Brad Bishop19323692019-04-05 15:28:33 -040028do_configure_prepend () {
Brad Bishop15ae2502019-06-18 21:44:24 -040029 # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
30 # This can be removed when upgrading to 1.1.34.
Brad Bishop19323692019-04-05 15:28:33 -040031 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
32
33 # The timestamps in the 1.1.28 tarball are messed up causing this file to
34 # appear out of date. Touch it so that we don't try to regenerate it.
35 touch ${S}/doc/xsltproc.1
36}
37
38EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}"
39# older versions of this recipe had ${PN}-utils
40RPROVIDES_${PN}-bin += "${PN}-utils"
41RCONFLICTS_${PN}-bin += "${PN}-utils"
42RREPLACES_${PN}-bin += "${PN}-utils"
43
44# This is only needed until libxml can load the relocated catalog itself
45do_install_append_class-native () {
46 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
47}
48
49FILES_${PN} += "${libdir}/libxslt-plugins"
50FILES_${PN}-dev += "${libdir}/xsltConf.sh"
51
52BBCLASSEXTEND = "native nativesdk"