blob: bba17962e25b4b239fb0b608b8edc0ddc815bbf6 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Libyui is a widget abstraction library providing Qt, GTK and ncurses frontends."
2LICENSE = "LGPLv3"
3LIC_FILES_CHKSUM = "file://COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \
4 file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \
5 file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
6 "
7
8SRC_URI = "git://github.com/libyui/libyui.git \
Brad Bishop316dfdd2018-06-25 12:45:53 -04009 file://0001-Fix-build-with-clang.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010 file://0001-Use-relative-install-paths-for-CMake.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040011 "
12
Andrew Geissler97771a32021-03-05 15:23:11 -060013SRCREV = "af06143017fc5f18c4b6488ba4aed26bcc43ff6e"
14
Brad Bishop316dfdd2018-06-25 12:45:53 -040015S = "${WORKDIR}/git"
16
17inherit cmake gettext pkgconfig
18
19DEPENDS += "boost"
20
Andrew Geissler97771a32021-03-05 15:23:11 -060021EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=RELWITHDEBINFO -DWERROR=OFF"
Brad Bishope42b3e32020-01-15 22:08:42 -050022
Brad Bishop316dfdd2018-06-25 12:45:53 -040023BBCLASSEXTEND = "native nativesdk"
24
Brad Bishop316dfdd2018-06-25 12:45:53 -040025do_install_append () {
26 if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then
27 mv ${D}/usr/lib64 ${D}/usr/lib
28 fi
29}
30
31do_install_append_class-nativesdk () {
32 mkdir -p ${D}/${base_prefix}
33 mv ${D}/usr ${D}/${base_prefix}
34}
35
36FILES_${PN}-dev = "${libdir}/* ${includedir}/yui*"