blob: 732880e96c3b286226a7c0c2a13fcaef8020ae56 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://tevent.samba.org"
3SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "LGPL-3.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005
6DEPENDS += "libtalloc libtirpc"
Patrick Williams213cb262021-08-07 19:21:33 -05007RDEPENDS:python3-tevent = "python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
9SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
Brad Bishop26bdd442019-08-16 17:08:17 -040010 file://options-0.10.0.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011 file://0001-libtevent-fix-musl-libc-compile-error.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000012 file://0001-Fix-pyext_PATTERN-for-cross-compilation.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013"
14LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a"
15
Andrew Geissler72956ed2021-01-08 16:11:14 -060016SRC_URI[md5sum] = "105c7a4dbb96f1751eb27dfd05e7fa84"
17SRC_URI[sha256sum] = "f8427822e5b2878fb8b28d6f50d96848734f3f3130612fb574fdd2d2148a6696"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
Andrew Geissler5199d832021-09-24 16:47:35 -050019inherit pkgconfig waf-samba
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21PACKAGECONFIG ??= "\
22 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
23 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
24"
25PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
26PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
27PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
28PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
29PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
30PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
31
32SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
33
34S = "${WORKDIR}/tevent-${PV}"
35
Brad Bishop26bdd442019-08-16 17:08:17 -040036#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
37#to cross Popen
38export WAF_NO_PREFORK="yes"
39
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040EXTRA_OECONF += "--disable-rpath \
41 --bundled-libraries=NONE \
42 --builtin-libraries=replace \
43 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
44 --without-gettext \
45 "
46
Brad Bishop26bdd442019-08-16 17:08:17 -040047PACKAGES += "python3-tevent"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080048
Patrick Williams213cb262021-08-07 19:21:33 -050049RPROVIDES:${PN}-dbg += "python3-tevent-dbg"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080050
Patrick Williams213cb262021-08-07 19:21:33 -050051FILES:python3-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
Brad Bishop26bdd442019-08-16 17:08:17 -040052
Patrick Williams213cb262021-08-07 19:21:33 -050053INSANE_SKIP:${MLPREFIX}python3-tevent = "dev-so"