blob: dbe2fd8157cad73771578c8b1428bc3740ec47b3 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Interface for user-level network packet capture"
2DESCRIPTION = "Libpcap provides a portable framework for low-level network \
3monitoring. Libpcap can provide network statistics collection, \
4security monitoring and network debugging."
5HOMEPAGE = "http://www.tcpdump.org/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=53067&atid=469577"
7SECTION = "libs/network"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04008LICENSE = "BSD-3-Clause"
Brad Bishop19323692019-04-05 15:28:33 -04009LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453 \
10 file://pcap.h;beginline=1;endline=32;md5=39af3510e011f34b8872f120b1dc31d2"
11DEPENDS = "flex-native bison-native"
12
Andrew Geissler09036742021-06-25 14:25:14 -050013SRC_URI = "https://www.tcpdump.org/release/${BP}.tar.gz"
14SRC_URI[sha256sum] = "ed285f4accaf05344f90975757b3dbfe772ba41d1c401c2648b7fa45b711bdd4"
Brad Bishop19323692019-04-05 15:28:33 -040015
Brad Bishop96ff1982019-08-19 13:50:42 -040016inherit autotools binconfig-disabled pkgconfig
Brad Bishop19323692019-04-05 15:28:33 -040017
18BINCONFIG = "${bindir}/pcap-config"
19
20# Explicitly disable dag support. We don't have recipe for it and if enabled here,
21# configure script poisons the include dirs with /usr/local/include even when the
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022# support hasn't been detected. Do the same thing for DPDK.
Brad Bishop19323692019-04-05 15:28:33 -040023EXTRA_OECONF = " \
24 --with-pcap=linux \
25 --without-dag \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000026 --without-dpdk \
Brad Bishop19323692019-04-05 15:28:33 -040027 "
28EXTRA_AUTORECONF += "--exclude=aclocal"
29
Brad Bishop96ff1982019-08-19 13:50:42 -040030PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
Brad Bishop19323692019-04-05 15:28:33 -040031 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
32"
33PACKAGECONFIG[bluez5] = "--enable-bluetooth,--disable-bluetooth,bluez5"
34PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
35PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
36PACKAGECONFIG[libnl] = "--with-libnl,--without-libnl,libnl"
37
Patrick Williams213cb262021-08-07 19:21:33 -050038do_configure:prepend () {
Brad Bishop19323692019-04-05 15:28:33 -040039 #remove hardcoded references to /usr/include
40 sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.ac
41}
42
43BBCLASSEXTEND = "native"