blob: 5a192a30536b2f6057ef47803c65514ef8f88abc [file] [log] [blame]
Brad Bishopce718f92017-01-12 22:12:01 -05001SUMMARY = "Phosphor Inventory Manager"
2DESCRIPTION = "Phosphor Inventory Manager is an inventory object \
3lifecycle management application, suitable for use on a wide variety \
4of OpenBMC platforms."
Brad Bishopce718f92017-01-12 22:12:01 -05005DEPENDS += " \
Brad Bishopbd44fa82019-05-22 19:21:40 -04006 phosphor-inventory-manager-assettag \
Brad Bishop286df172017-02-13 22:51:36 -05007 phosphor-dbus-interfaces \
Brad Bishop15947ed2017-02-15 14:11:50 -05008 phosphor-logging \
Brad Bishopce718f92017-01-12 22:12:01 -05009 sdbusplus \
Patrick Williams4b32c9a2020-03-31 16:43:15 -050010 ${PYTHON_PN}-sdbus++-native \
Brad Bishop17c08bf2018-10-18 17:07:53 -040011 libcereal \
Andrew Geisslerb49af0c2020-03-05 09:27:35 -060012 ${PYTHON_PN}-native \
13 ${PYTHON_PN}-pyyaml-native \
14 ${PYTHON_PN}-mako-native \
George Liu563b6de2022-05-23 10:36:40 +080015 nlohmann-json \
Brad Bishopce718f92017-01-12 22:12:01 -050016 "
Ed Tanous9936f862022-09-19 09:13:20 -070017PACKAGECONFIG ??= ""
18PACKAGECONFIG[associations] = "-Dassociations=enabled, -Dassociations=disabled"
19PV = "1.0+git${SRCPV}"
20PR = "r1"
Brad Bishopce718f92017-01-12 22:12:01 -050021
22S = "${WORKDIR}/git"
23
Ed Tanous9936f862022-09-19 09:13:20 -070024inherit meson \
25 pkgconfig \
26 python3native \
27 phosphor-dbus-yaml \
28 phosphor-inventory-manager \
29 obmc-phosphor-dbus-service
30
George Liu563b6de2022-05-23 10:36:40 +080031EXTRA_OEMESON = " \
32 -Dtests=disabled \
33 -DYAML_PATH=${STAGING_DIR_HOST}${base_datadir} \
34 -DIFACES_PATH=${STAGING_DIR_TARGET}${yaml_dir} \
Brad Bishopce718f92017-01-12 22:12:01 -050035 "
Matt Spinler0bf37932019-03-11 16:24:03 -050036
Ed Tanous9936f862022-09-19 09:13:20 -070037require phosphor-inventory-manager.inc
38
39OBMC_INVENTORY_PATH = "${OBMC_DBUS_PATH_ROOT}/inventory"
40OBMC_INVENTORY_MGR_IFACE = "${OBMC_DBUS_IFACE_ROOT}.Inventory.Manager"
41DBUS_SERVICE:${PN} = "${OBMC_INVENTORY_MGR_IFACE}.service"