blob: cebc9526616720a662c6755c4c547318e10ed5b5 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
9LICENSE = "GPLv2 & LGPLv2.1"
10LIC_FILES_CHKSUM = " \
11 file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
12 file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
13"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015DEPENDS = "libsamplerate0 libsndfile1 readline"
Patrick Williamsddad1a12017-02-23 20:36:32 -060016
Brad Bishop00ab2372019-10-14 11:06:18 -040017SRC_URI = "git://github.com/jackaudio/jack2.git"
Brad Bishop996bc452019-12-02 13:05:15 -050018SRCREV = "b54a09bf7ef760d81fdb8544ad10e45575394624"
19
Patrick Williamsddad1a12017-02-23 20:36:32 -060020S = "${WORKDIR}/git"
21
22inherit waf pkgconfig
23
24PACKAGECONFIG ??= "alsa"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
Brad Bishop19323692019-04-05 15:28:33 -040026# --dbus only stops building jackd -> add --classic
27PACKAGECONFIG[dbus] = "--dbus --classic,,dbus"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
Patrick Williamsddad1a12017-02-23 20:36:32 -060029
30# portaudio is for windows builds only
31EXTRA_OECONF = "--portaudio=no"
32
Brad Bishop996bc452019-12-02 13:05:15 -050033do_install_append() {
34 if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then
35 rm -f ${D}${bindir}/jack_control
36 fi
37}
38
Patrick Williamsddad1a12017-02-23 20:36:32 -060039PACKAGES =+ "libjack jack-server jack-utils"
40
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041RDEPENDS_jack-dev_remove = "${PN} (= ${EXTENDPKGV})"
42
Patrick Williamsddad1a12017-02-23 20:36:32 -060043FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
Brad Bishop19323692019-04-05 15:28:33 -040044FILES_jack-server = " \
45 ${datadir}/dbus-1/services \
46 ${bindir}/jackdbus \
47 ${bindir}/jackd \
48"
Patrick Williamsddad1a12017-02-23 20:36:32 -060049FILES_jack-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040050
Brad Bishop996bc452019-12-02 13:05:15 -050051FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*"