blob: 6bf321e2372d6bea6206cf12bdd012ac0503257a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Yet Another Flash File System"
2DESCRIPTION = "Tools for managing 'yaffs2' file systems."
3
4SECTION = "base"
5HOMEPAGE = "http://www.yaffs.net"
6
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-2.0-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=11;endline=13;md5=5f5464f9b3e981ca574e65b00e438561 \
9 file://utils/mkyaffsimage.c;beginline=10;endline=12;md5=5f5464f9b3e981ca574e65b00e438561 \
10 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
12PV = "0.0+git${SRCPV}"
13
14DEPENDS = "mtd-utils"
15
16# Source is the HEAD of master branch at the time of writing this recipe
Patrick Williamsddad1a12017-02-23 20:36:32 -060017SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master \
18 file://makefile-add-ldflags.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019 file://0001-define-loff_t-if-not-already-defined.patch \
20 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060021
Andrew Geissler72956ed2021-01-08 16:11:14 -060022SRCREV = "9a6f486e56f927eeb8dc7e4e0d84f6bb95eeaa0f"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023
24UPSTREAM_CHECK_COMMITS = "1"
25
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026S = "${WORKDIR}/git"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028CFLAGS:append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050029EXTRA_OEMAKE = "-e MAKEFLAGS="
30
31do_compile() {
32 cd utils && oe_runmake
33}
34
35INSTALL_FILES = "mkyaffsimage \
36 mkyaffs2image \
37 "
38do_install() {
39 install -d ${D}${sbindir}/
40 for i in ${INSTALL_FILES}; do
41 install -m 0755 utils/$i ${D}${sbindir}/
42 done
43}
44
45BBCLASSEXTEND = "native"
Brad Bishop19323692019-04-05 15:28:33 -040046
47# Fixed make clean error:
48#make -C /lib/modules/4.4.0-112-generic/build M=<snip>
49#make: *** /lib/modules/4.4.0-112-generic/build: No such file or directory. Stop.
50#make: *** [clean] Error 2
51CLEANBROKEN = "1"