blob: 07a67b9634884dc01746124eb6a9289de367c12c [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Compressor/archiver for creating and modifying .zip files"
2HOMEPAGE = "http://www.info-zip.org"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "Info-ZIP's purpose is to provide free, portable, high-quality versions of the Zip and UnZip compressor-archiver utilities that are compatible with the DOS-based PKZIP by PKWARE, Inc."
Patrick Williamsc0f7c042017-02-23 20:41:17 -06004SECTION = "console/utils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
Patrick Williamsc0f7c042017-02-23 20:41:17 -06009PR = "r2"
10
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011S = "${WORKDIR}/zip30"
12
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/Zip%203.x%20%28latest%29/3.0/zip30.tar.gz \
Brad Bishop15ae2502019-06-18 21:44:24 -040014 file://fix-security-format.patch \
15 file://10-remove-build-date.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 file://zipnote-crashes-with-segfault.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000017 file://0001-configure-use-correct-CPP.patch \
18 file://0002-configure-support-PIC-code-build.patch \
19 file://0001-configure-Use-CFLAGS-and-LDFLAGS-when-doing-link-tes.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040020 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021UPSTREAM_VERSION_UNKNOWN = "1"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37"
24SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369"
25
Andrew Geisslerd1e89492021-02-12 15:35:20 -060026# Disputed and also Debian doesn't consider a vulnerability
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000027CVE_CHECK_IGNORE += "CVE-2018-13410"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060028
29# Not for zip but for smart contract implementation for it
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000030CVE_CHECK_IGNORE += "CVE-2018-13684"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060031
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032# zip.inc sets CFLAGS, but what Makefile actually uses is
33# CFLAGS_NOOPT. It will also force -O3 optimization, overriding
34# whatever we set.
Patrick Williamsc0f7c042017-02-23 20:41:17 -060035EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
36 'CFLAGS=-I. -DUNIX ${CFLAGS}' \
37 'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}' \
38 'INSTALL=install' 'INSTALL_D=install -d' \
39 'BINFLAGS=0755'"
40
41do_compile() {
42 oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
43 sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
44 oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
45}
46
47do_install() {
48 oe_runmake -f unix/Makefile prefix=${D}${prefix} \
49 BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
50 install
51}
52
53BBCLASSEXTEND = "native"
54
55# exclude version 2.3.2 which triggers a false positive
56UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"