blob: 8940a83644e22baf76bc0540b46a2b49afd3fb27 [file] [log] [blame]
Jie Yang7fe1bad2021-08-06 12:41:16 -07001SUMMARY = "GLOME Login Client"
2DESCRIPTION = "GLOME login is first application of the GLOME protocol. It is used to authorize serial console access to Linux machines"
3PR = "r1"
4PV = "0.1+git${SRCPV}"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
9inherit meson pkgconfig
10
Leo Tu9104c302022-08-18 05:17:39 +000011DEPENDS += " \
12 openssl \
13 glome-config \
14 "
Jie Yang7fe1bad2021-08-06 12:41:16 -070015
16S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060017SRC_URI = "git://github.com/google/glome.git;branch=master;protocol=https"
William A. Kennington III9c5d7fa2022-07-08 14:39:13 -070018SRCREV = "978ad9fb165f1e382c875f2ce08a1fc4f2ddcf1b"
Jie Yang7fe1bad2021-08-06 12:41:16 -070019
Jie Yang7fe1bad2021-08-06 12:41:16 -070020PACKAGECONFIG ??= ""
21PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
22PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
23
William A. Kennington III9c5d7fa2022-07-08 14:39:13 -070024EXTRA_OEMESON = "-Dtests=false"
Leo Tu9104c302022-08-18 05:17:39 +000025
26# remove the default glome config so it can be overridden by `glome-config`
27do_install:append() {
28 rm -f ${D}${sysconfdir}/glome/config
29}