blob: b9d6225d2774729a17f819552a2536dd7aab0d72 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require grub2.inc
2
Brad Bishopa34c0302019-09-23 22:34:48 -04003require conf/image-uefi.conf
4
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005GRUBPLATFORM = "efi"
6
7DEPENDS_append_class-target = " grub-efi-native"
Brad Bishopa34c0302019-09-23 22:34:48 -04008RDEPENDS_${PN}_class-target = "grub-common virtual/grub-bootconf"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
10SRC_URI += " \
11 file://cfg \
12 "
13
14S = "${WORKDIR}/grub-${PV}"
15
16# Determine the target arch for the grub modules
17python __anonymous () {
18 import re
19 target = d.getVar('TARGET_ARCH')
Brad Bishop316dfdd2018-06-25 12:45:53 -040020 prefix = "" if d.getVar('EFI_PROVIDER') == "grub-efi" else "grub-efi-"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021 if target == "x86_64":
22 grubtarget = 'x86_64'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023 elif re.match('i.86', target):
24 grubtarget = 'i386'
Brad Bishop316dfdd2018-06-25 12:45:53 -040025 elif re.match('aarch64', target):
26 grubtarget = 'arm64'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027 elif re.match('arm', target):
28 grubtarget = 'arm'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050029 else:
Brad Bishop316dfdd2018-06-25 12:45:53 -040030 raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target)
Brad Bishopa34c0302019-09-23 22:34:48 -040031 grubimage = prefix + d.getVar("EFI_BOOT_IMAGE")
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032 d.setVar("GRUB_TARGET", grubtarget)
33 d.setVar("GRUB_IMAGE", grubimage)
Brad Bishop316dfdd2018-06-25 12:45:53 -040034 prefix = "grub-efi-" if prefix == "" else ""
35 d.setVar("GRUB_IMAGE_PREFIX", prefix)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050036}
37
38inherit deploy
39
40CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN="
41EXTRA_OECONF += "--enable-efiemu=no"
42
Brad Bishop316dfdd2018-06-25 12:45:53 -040043do_mkimage() {
44 cd ${B}
45 # Search for the grub.cfg on the local boot media by using the
46 # built in cfg file provided via this recipe
Brad Bishopa34c0302019-09-23 22:34:48 -040047 grub-mkimage -c ../cfg -p ${EFIDIR} -d ./grub-core/ \
Brad Bishop316dfdd2018-06-25 12:45:53 -040048 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} \
49 ${GRUB_BUILDIN}
50}
51
52addtask mkimage before do_install after do_compile
53
54do_mkimage_class-native() {
55 :
56}
57
58do_install_append_class-target() {
Brad Bishopa34c0302019-09-23 22:34:48 -040059 install -d ${D}${EFI_FILES_PATH}
60 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${D}${EFI_FILES_PATH}/${GRUB_IMAGE}
Brad Bishop316dfdd2018-06-25 12:45:53 -040061}
62
Brad Bishopd7bf8c12018-02-25 22:55:05 -050063do_install_class-native() {
64 install -d ${D}${bindir}
65 install -m 755 grub-mkimage ${D}${bindir}
Brad Bishopc342db32019-05-15 21:57:59 -040066 install -m 755 grub-editenv ${D}${bindir}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050067}
68
Brad Bishop316dfdd2018-06-25 12:45:53 -040069do_install_class-target() {
70 oe_runmake 'DESTDIR=${D}' -C grub-core install
71
Brad Bishopd7bf8c12018-02-25 22:55:05 -050072 # Remove build host references...
73 find "${D}" -name modinfo.sh -type f -exec \
74 sed -i \
75 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
76 -e 's|${DEBUG_PREFIX_MAP}||g' \
77 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
78 {} +
79}
80
Brad Bishop08902b02019-08-20 09:16:51 -040081do_install_append_aarch64() {
82 rm -rf ${D}/${prefix}/
83}
84
Brad Bishopd7bf8c12018-02-25 22:55:05 -050085GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal \
Brad Bishop316dfdd2018-06-25 12:45:53 -040086 efi_gop iso9660 configfile search loadenv test"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050087
88do_deploy() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040089 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${DEPLOYDIR}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050090}
91
92do_deploy_class-native() {
93 :
94}
95
96addtask deploy after do_install before do_build
97
Brad Bishop316dfdd2018-06-25 12:45:53 -040098FILES_${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \
99 ${datadir}/grub \
Brad Bishopa34c0302019-09-23 22:34:48 -0400100 ${EFI_FILES_PATH}/${GRUB_IMAGE} \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400101 "
102
Brad Bishop08902b02019-08-20 09:16:51 -0400103FILES_${PN}_remove_aarch64 = "${libdir}/grub/${GRUB_TARGET}-efi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500104
105# 64-bit binaries are expected for the bootloader with an x32 userland
106INSANE_SKIP_${PN}_append_linux-gnux32 = " arch"
107INSANE_SKIP_${PN}-dbg_append_linux-gnux32 = " arch"
108INSANE_SKIP_${PN}_append_linux-muslx32 = " arch"
109INSANE_SKIP_${PN}-dbg_append_linux-muslx32 = " arch"