Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "The Bitstream Vera fonts - TTF Edition" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://www.gnome.org/fonts/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | DESCRIPTION = "The Bitstream Vera fonts include four monospace and sans \ |
| 4 | faces (normal, oblique, bold, bold oblique) and two serif faces (normal \ |
| 5 | and bold). In addition Fontconfig/Xft2 can artificially oblique the \ |
| 6 | serif faces for you: this loses hinting and distorts the faces slightly, \ |
| 7 | but is visibly different than normal and bold, and reasonably pleasing." |
| 8 | SECTION = "x11/fonts" |
| 9 | LICENSE = "BitstreamVera" |
| 10 | LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 11 | PR = "r8" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 13 | inherit allarch fontcache |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 15 | # remove at next version upgrade or when output changes |
| 16 | HASHEQUIV_HASH_VERSION .= ".1" |
| 17 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | FONT_PACKAGES = "${PN}" |
| 19 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 20 | SRC_URI = "${GNOME_MIRROR}/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 21 | SRC_URI[md5sum] = "bb22bd5b4675f5dbe17c6963d8c00ed6" |
| 22 | SRC_URI[sha256sum] = "db5b27df7bbb318036ebdb75acd3e98f1bd6eb6608fb70a67d478cd243d178dc" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 23 | |
| 24 | do_install () { |
| 25 | install -d ${D}${datadir}/fonts/ttf |
| 26 | for i in *.ttf; do |
| 27 | install -m 644 $i ${D}${datadir}/fonts/ttf |
| 28 | done |
| 29 | |
| 30 | install -d ${D}${docdir}/${BPN} |
| 31 | for i in *.TXT; do |
| 32 | install -m 644 $i ${D}${docdir}/${BPN} |
| 33 | done |
| 34 | } |
| 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | FILES:${PN} = "${datadir}/fonts" |