blob: 75791cfc0a5351827eb0048f94cae1882a224325 [file] [log] [blame]
Brad Bishop4c3712f2019-04-24 19:44:31 -04001inherit systemd
Ed Tanous2c2a1c52018-01-29 10:56:52 -08002inherit useradd
3
4USERADD_PACKAGES = "${PN}"
5
6# add a user called httpd for the server to assume
7USERADD_PARAM_${PN} = "-r -s /usr/sbin/nologin bmcweb"
Richard Marian Thomaiyar8ac94ce2018-08-20 20:14:16 +05308GROUPADD_PARAM_${PN} = "web; redfish"
Ed Tanous2c2a1c52018-01-29 10:56:52 -08009
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
12
Ed Tanous6e3195d2018-03-20 08:42:54 -070013SRC_URI = "git://github.com/openbmc/bmcweb.git"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080014
15PV = "1.0+git${SRCPV}"
Andrew Geissleref606662021-03-22 17:31:00 +000016SRCREV = "8f7e9c194f36a84f4e49ad142110f4f3d0f312be"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080017
18S = "${WORKDIR}/git"
19
Ed Tanousa443c542021-02-26 13:28:37 -080020inherit meson ptest
21
22SRC_URI += " \
23 file://run-ptest \
24"
25
Ed Tanous07f48cc2021-02-22 10:49:30 -080026DEPENDS = " \
27 openssl \
28 zlib \
29 boost \
30 boost-url \
31 libpam \
32 sdbusplus \
33 gtest \
34 nlohmann-json \
35 libtinyxml2 \
Ed Tanousa443c542021-02-26 13:28:37 -080036 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \
37 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \
Ed Tanous07f48cc2021-02-22 10:49:30 -080038"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080039
Ed Tanous07f48cc2021-02-22 10:49:30 -080040RDEPENDS_${PN} += " \
41 jsnbd \
Ed Tanous4073a4f2021-02-22 10:50:59 -080042 phosphor-mapper \
Ed Tanous07f48cc2021-02-22 10:49:30 -080043"
Adriana Kobylak7e0ff54f2018-12-13 11:01:05 -060044
Ed Tanousa443c542021-02-26 13:28:37 -080045do_install_ptest() {
46 install -d ${D}${PTEST_PATH}/test
47 cp -rf ${B}*_test ${D}${PTEST_PATH}/test/
48}
49
Ed Tanous2c2a1c52018-01-29 10:56:52 -080050FILES_${PN} += "${datadir}/** "
51
Ed Tanous2c2a1c52018-01-29 10:56:52 -080052
Ed Tanousa443c542021-02-26 13:28:37 -080053EXTRA_OEMESON = " \
54 --buildtype=minsize \
55 -Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \
56 -Dyocto-deps=enabled \
57"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080058
Ed Tanous74a89f92018-07-17 10:20:09 -070059SYSTEMD_SERVICE_${PN} += "bmcweb.service bmcweb.socket"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080060
Manojkiran Edaf1f2e242020-09-02 21:48:12 +053061FULL_OPTIMIZATION = "-Os "