blob: 74550efd14fa85da4177ee6be318586e94e3e9d7 [file] [log] [blame]
Andrew Geissler26e4bea2020-11-30 19:54:03 -06001SUMMARY = "cmdline.txt file used to boot the kernel on a Raspberry Pi device"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5COMPATIBLE_MACHINE = "^rpi$"
6INHIBIT_DEFAULT_DEPS = "1"
7inherit deploy nopackages
8
9CMDLINE_DWC_OTG ?= "dwc_otg.lpm_enable=0"
Andrew Geisslerad7fa352021-07-23 12:55:23 -040010
11CMDLINE_ROOT_FSTYPE ?= "rootfstype=ext4"
12CMDLINE_ROOTFS ?= "root=/dev/mmcblk0p2 ${CMDLINE_ROOT_FSTYPE} rootwait"
Andrew Geissler26e4bea2020-11-30 19:54:03 -060013
14CMDLINE_SERIAL ?= "${@oe.utils.conditional("ENABLE_UART", "1", "console=serial0,115200", "", d)}"
15
16CMDLINE_CMA ?= "${@oe.utils.conditional("RASPBERRYPI_CAMERA_V2", "1", "cma=64M", "", d)}"
17
William A. Kennington IIIa99e9b62021-06-02 12:47:56 -070018CMDLINE_CMA ?= "${@oe.utils.conditional("RASPBERRYPI_HD_CAMERA", "1", "cma=64M", "", d)}"
19
Andrew Geissler26e4bea2020-11-30 19:54:03 -060020CMDLINE_PITFT ?= "${@bb.utils.contains("MACHINE_FEATURES", "pitft", "fbcon=map:10 fbcon=font:VGA8x8", "", d)}"
21
22# Add the kernel debugger over console kernel command line option if enabled
23CMDLINE_KGDB ?= '${@oe.utils.conditional("ENABLE_KGDB", "1", "kgdboc=serial0,115200", "", d)}'
24
25# Disable rpi logo on boot
26CMDLINE_LOGO ?= '${@oe.utils.conditional("DISABLE_RPI_BOOT_LOGO", "1", "logo.nologo", "", d)}'
27
28# You can define CMDLINE_DEBUG as "debug" in your local.conf or distro.conf
29# to enable kernel debugging.
30CMDLINE_DEBUG ?= ""
31
32CMDLINE = " \
33 ${CMDLINE_DWC_OTG} \
34 ${CMDLINE_SERIAL} \
35 ${CMDLINE_ROOTFS} \
36 ${CMDLINE_CMA} \
37 ${CMDLINE_KGDB} \
38 ${CMDLINE_LOGO} \
39 ${CMDLINE_PITFT} \
40 ${CMDLINE_DEBUG} \
41 "
42
43do_compile() {
Andrew Geissler11105212021-02-12 15:30:38 -060044 echo "${@' '.join('${CMDLINE}'.split())}" > "${WORKDIR}/cmdline.txt"
Andrew Geissler26e4bea2020-11-30 19:54:03 -060045}
46
47do_deploy() {
48 install -d "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
49 install -m 0644 "${WORKDIR}/cmdline.txt" "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
50}
51
52addtask deploy before do_build after do_install
53do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
Andrew Geisslera4353c82021-06-25 14:23:27 -050054
55PACKAGE_ARCH = "${MACHINE_ARCH}"