blob: a6857a39814cc39d48171b29415f5a76d94dd421 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A portable foreign function interface library"
2HOMEPAGE = "http://sourceware.org/libffi/"
3DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
Patrick Williams73bd93f2024-02-20 08:07:48 -060011LIC_FILES_CHKSUM = "file://LICENSE;md5=1db54c9fd307a12218766c3c7f650ca7"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BPN}-${PV}.tar.gz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050014 file://not-win32.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 "
Patrick Williams39653562024-03-01 08:54:02 -060016SRC_URI[sha256sum] = "b0dea9df23c863a7a50e825440f3ebffabd65df1497108e5d437747843895a4e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
Andrew Geissler5f350902021-07-23 13:09:54 -040018EXTRA_OECONF += "--disable-builddir --disable-exec-static-tramp"
Andrew Geissler615f2f12022-07-15 14:00:58 -050019EXTRA_OECONF:class-native += "--with-gcc-arch=generic"
Patrick Williams213cb262021-08-07 19:21:33 -050020EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'"
Patrick Williams73bd93f2024-02-20 08:07:48 -060021
Andrew Geissler87f5cff2022-09-30 13:13:31 -050022inherit autotools texinfo multilib_header github-releases
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
Patrick Williams213cb262021-08-07 19:21:33 -050024do_install:append() {
Andrew Geissler635e0e42020-08-21 15:58:33 -050025 oe_multilib_header ffi.h ffitarget.h
Andrew Geissler82c905d2020-04-13 13:39:40 -050026}
27
Andrew Geissler82c905d2020-04-13 13:39:40 -050028# Doesn't compile in MIPS16e mode due to use of hand-written
29# assembly
30MIPS_INSTRUCTION_SET = "mips"
31
32BBCLASSEXTEND = "native nativesdk"