blob: dd2c5e9570745846e63f7483ad6951c93cee9d74 [file] [log] [blame]
Patrick Williams9e206392017-01-19 21:20:46 -06001SUMMARY = "Phosphor State Management"
2DESCRIPTION = "Phosphor State Manager provides a set of system state \
3management daemons. It is suitable for use on a wide variety of OpenBMC \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10STATE_MGR_PACKAGES = " \
11 ${PN}-host \
12 ${PN}-chassis \
Josh Kingd2b95c72017-01-19 14:04:03 -060013 ${PN}-bmc \
Michael Tritzb6e965c2017-04-18 17:01:12 -050014 ${PN}-discover \
Patrick Williams9e206392017-01-19 21:20:46 -060015"
16PACKAGES =+ "${STATE_MGR_PACKAGES}"
Brad Bishop1a5a5972017-03-01 16:08:45 -050017PACKAGES_remove = "${PN}"
18RDEPENDS_${PN}-dev = "${STATE_MGR_PACKAGES}"
19RDEPENDS_${PN}-staticdev = "${STATE_MGR_PACKAGES}"
20
Patrick Williams9e206392017-01-19 21:20:46 -060021DBUS_PACKAGES = "${STATE_MGR_PACKAGES}"
22
23# Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES
24# handles the rest.
25SYSTEMD_PACKAGES = ""
26
27inherit autotools pkgconfig
28inherit obmc-phosphor-dbus-service
29
30DEPENDS += "autoconf-archive-native"
31DEPENDS += "sdbusplus"
32DEPENDS += "phosphor-logging"
Patrick Williams1815f6b2017-01-30 11:06:16 -060033DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylak86354212017-01-30 20:30:00 -060034RDEPENDS_${PN} += "sdbusplus"
Patrick Williams9e206392017-01-19 21:20:46 -060035
Patrick Williams1815f6b2017-01-30 11:06:16 -060036RDEPENDS_${PN}-host += "libsystemd phosphor-dbus-interfaces"
37RDEPENDS_${PN}-chassis += "libsystemd phosphor-dbus-interfaces"
38RDEPENDS_${PN}-bmc += "libsystemd phosphor-dbus-interfaces"
Michael Tritzb6e965c2017-04-18 17:01:12 -050039RDEPENDS_${PN}-discover += "libsystemd phosphor-dbus-interfaces"
Patrick Williams9e206392017-01-19 21:20:46 -060040
Patrick Williams9e206392017-01-19 21:20:46 -060041FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager"
42DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service"
43
Patrick Williams9e206392017-01-19 21:20:46 -060044FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager"
45DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service"
46
Josh Kingd2b95c72017-01-19 14:04:03 -060047FILES_${PN}-bmc = "${sbindir}/phosphor-bmc-state-manager"
48DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service"
49
Michael Tritzb6e965c2017-04-18 17:01:12 -050050FILES_${PN}-discover = "${sbindir}/phosphor-discover-system-state"
51
Patrick Williams9e206392017-01-19 21:20:46 -060052SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
Michael Tritzb6e965c2017-04-18 17:01:12 -050053SRCREV = "3ed10085ae988b08e8230d35693d370bf75f0574"
Patrick Williams9e206392017-01-19 21:20:46 -060054
55S = "${WORKDIR}/git"