blob: 62b8d32057215f93c3db703ead9d6c72f2cf2546 [file] [log] [blame]
Vijay Khemka66070d32020-07-23 15:22:56 -07001SUMMARY = "BMC Health Monitoring"
2DESCRIPTION = "Daemon to collect and monitor bmc health statistics"
3HOMEPAGE = "https://github.com/openbmc/phosphor-health-monitor"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
7
8inherit meson pkgconfig
9inherit systemd
10
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "sdeventplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "nlohmann-json"
16
Patrick Williamsbb99d222022-01-24 15:55:09 -060017SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=https;branch=master"
Andrew Geissler03966b52021-12-22 16:21:09 +000018SRCREV = "a6cd704bda72e39e1b94652a9eb0733da8498791"
Vijay Khemka66070d32020-07-23 15:22:56 -070019S = "${WORKDIR}/git"
20
Patrick Williams12fc9392021-08-06 09:16:53 -050021SYSTEMD_SERVICE:${PN} = "phosphor-health-monitor.service"