blob: ea3dedcc101e4a26813335cf8742f2af9dca3908 [file] [log] [blame]
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +05301SUMMARY = "Phosphor Physical LED Controller daemon"
2DESCRIPTION = "Daemon to trigger actions on a physical LED"
3HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs"
4PR = "r1"
Patrick Venture195cf9d2018-10-02 20:54:25 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venture195cf9d2018-10-02 20:54:25 -07008
George Liu54514762021-05-28 14:53:31 +08009inherit meson pkgconfig
Brad Bishop807fdd22017-01-26 12:36:52 -050010inherit obmc-phosphor-dbus-service
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +053011
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +053012DEPENDS += "sdbusplus"
Brad Bishop44f3cce2019-03-22 23:41:42 -040013DEPENDS += "systemd"
Xo Wang0d7ad402017-03-14 16:40:31 -070014DEPENDS += "phosphor-dbus-interfaces"
Andrew Geissler39b2f922019-06-25 02:12:26 +000015DEPENDS += "boost"
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +053016
Patrick Williams12fc9392021-08-06 09:16:53 -050017DBUS_SERVICE:${PN} += "xyz.openbmc_project.led.controller@.service"
Brad Bishop807fdd22017-01-26 12:36:52 -050018
Patrick Williamsed104d42021-08-31 13:19:27 -050019EXTRA_OEMESON:append = " -Dtests=disabled"
William A. Kennington III088a2ba2021-06-02 13:27:47 -070020
Patrick Williamsbb99d222022-01-24 15:55:09 -060021SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs;branch=master;protocol=https"
Brad Bishop807fdd22017-01-26 12:36:52 -050022SRC_URI += "file://70-leds.rules"
Andrew Geissler687a8322022-01-20 02:40:22 +000023SRCREV = "1f2b932bb9ef88d97a6313f4dc087fb1f2eb399a"
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +053024S = "${WORKDIR}/git"
Brad Bishop807fdd22017-01-26 12:36:52 -050025
Patrick Williams12fc9392021-08-06 09:16:53 -050026do_install:append() {
Anton Blanchard782d7192021-08-16 23:51:27 -060027 install -d ${D}/${nonarch_base_libdir}/udev/rules.d/
28 install -m 0644 ${WORKDIR}/70-leds.rules ${D}/${nonarch_base_libdir}/udev/rules.d/
Brad Bishop807fdd22017-01-26 12:36:52 -050029}