blob: 0f5ef7052c165241332156f84fe25d9fcadd3158 [file] [log] [blame]
James Feiste3322992018-10-04 16:15:37 -07001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05005LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=dd0607f896f392c8b7d0290a676efc24"
James Feiste3322992018-10-04 16:15:37 -07006
Andrew Geisslerdce5cf92020-05-17 11:54:15 -05007SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1 \
Andrew Geisslerdce5cf92020-05-17 11:54:15 -05008 "
James Feiste3322992018-10-04 16:15:37 -07009
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050010SRCREV = "d34771cafc87b358ba421faca28facc7f8080174"
James Feiste3322992018-10-04 16:15:37 -070011
12S = "${WORKDIR}/git"
13
14inherit cmake
15
16EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
17
18# nlohmann-json is a header only C++ library, so the main package will be empty.
19
20RDEPENDS_${PN}-dev = ""
21
22BBCLASSEXTEND = "native nativesdk"
James Feistcb07cdf2018-10-11 13:47:04 -070023
24# other packages commonly reference the file directly as "json.hpp"
25# create symlink to allow this usage
26do_install_append() {
27 ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
28}