blob: 5766194d269414ba7dd65fdc2b97a85c0da5dac5 [file] [log] [blame]
James Feiste3322992018-10-04 16:15:37 -07001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
Brad Bishop2d39a062019-10-28 08:33:36 -04005LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f5f7c71504da070bcf4f090205ce1080"
James Feiste3322992018-10-04 16:15:37 -07006
Andrew Geisslerdce5cf92020-05-17 11:54:15 -05007SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1 \
8 file://0001-Templatize-basic_json-ctor-from-json_ref.patch \
9 file://0001-typo-fix.patch \
10 "
James Feiste3322992018-10-04 16:15:37 -070011
Brad Bishope42b3e32020-01-15 22:08:42 -050012SRCREV = "e7b3b40b5a95bc74b9a7f662830a27c49ffc01b4"
James Feiste3322992018-10-04 16:15:37 -070013
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
19
20# nlohmann-json is a header only C++ library, so the main package will be empty.
21
22RDEPENDS_${PN}-dev = ""
23
24BBCLASSEXTEND = "native nativesdk"
James Feistcb07cdf2018-10-11 13:47:04 -070025
26# other packages commonly reference the file directly as "json.hpp"
27# create symlink to allow this usage
28do_install_append() {
29 ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
30}