blob: c8155a72f67496c707d5ee7e704f5d8e95652bde [file] [log] [blame]
Zane Shelley67143732021-03-23 17:08:45 -05001SUMMARY = "Hardware Diagnostics for POWER Systems"
Brad Bishopfac997f2020-02-03 17:09:22 -05002
Zane Shelley67143732021-03-23 17:08:45 -05003DESCRIPTION = \
4 "In the event of a system fatal error reported by the internal system \
5 hardware (processor chips, memory chips, I/O chips, system memory, etc.), \
6 POWER Systems have the ability to diagnose the root cause of the failure \
7 and perform any service action needed to avoid repeated system failures."
8
Zane Shelley92804a72021-06-04 17:18:22 -05009HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
10
Brad Bishopfac997f2020-02-03 17:09:22 -050011LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
13
Zane Shelley92804a72021-06-04 17:18:22 -050014PR = "r1"
15PV = "0.1+git${SRCPV}"
Brad Bishopfac997f2020-02-03 17:09:22 -050016
Patrick Williamsbb99d222022-01-24 15:55:09 -060017SRC_URI = "git://github.com/openbmc/openpower-hw-diags;branch=master;protocol=https"
Andrew Geisslerc0a0fb62023-09-18 09:50:34 -050018SRCREV = "c3038c033f621c2b52d75a625c68040bde77fb3b"
Zane Shelley67143732021-03-23 17:08:45 -050019
Zane Shelley92804a72021-06-04 17:18:22 -050020S = "${WORKDIR}/git"
21
Andrew Geisslerbaf5ba72021-11-03 10:01:23 -050022inherit pkgconfig meson systemd
Zane Shelley92804a72021-06-04 17:18:22 -050023
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000024SYSTEMD_SERVICE:${PN} = "attn_handler.service"
Zane Shelley67143732021-03-23 17:08:45 -050025
Zane Shelleyb6d95ee2021-02-10 17:43:44 -060026DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \
Zane Shelley75174d32022-02-01 17:04:08 -060027 nlohmann-json valijson fmt"
Zane Shelleyb6d95ee2021-02-10 17:43:44 -060028
Zane Shelley8dff99b2020-11-10 19:56:40 -060029# This is required so that libhei is installed with the chip data files.
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000030RDEPENDS:${PN} += "openpower-libhei"
Zane Shelleyaa8acf12021-03-23 17:13:08 -050031
32# Conditionally pull in PHAL APIs, if available.
Patrick Williams8c561ee2021-10-22 14:20:12 -050033PACKAGECONFIG ??= "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}"
Ben Tyner2ded4812021-10-12 15:20:11 -050034PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, ipl pdata"
Zane Shelleyaa8acf12021-03-23 17:13:08 -050035
Zane Shelley896d1422022-01-14 13:09:44 -060036# Don't build CI tests
37EXTRA_OEMESON = "-Dtests=disabled"
38
Andrew Geissler1a6eedc2023-05-16 08:20:14 -050039pkg_postinst:${PN}() {
40 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
41 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/attn_handler.service"
42 TARGET="../attn_handler.service"
43 ln -s $TARGET $LINK
44}
45
46pkg_prerm:${PN}() {
47 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/attn_handler.service"
48 rm $LINK
49}