blob: a2e0ba5287c9a6277e57033d7c5dc0be6c53bcb7 [file] [log] [blame]
Matt Spinlerb45c1822018-03-26 16:23:38 -05001SUMMARY = "IBM DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the IBM YAML"
3PR = "r1"
Patrick Venture56e154e2018-10-17 15:10:55 -07004PV = "1.0+git${SRCPV}"
Patrick Venturec484d322018-11-03 08:36:39 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Matt Spinlerb45c1822018-03-26 16:23:38 -05007
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
Matt Spinlerb45c1822018-03-26 16:23:38 -050011inherit pythonnative
12inherit phosphor-dbus-yaml
13
14DEPENDS += "autoconf-archive-native"
15DEPENDS += "sdbus++-native"
16
17SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces"
Andrew Geisslerf617bc82018-10-04 21:30:14 +000018SRCREV = "c9ae6bf297b40391256c8f21a01d72e049036017"
Matt Spinlerb45c1822018-03-26 16:23:38 -050019
20DEPENDS_remove_class-native = "sdbus++-native"
21DEPENDS_remove_class-nativesdk = "sdbus++-native"
22
23PACKAGECONFIG ??= "libibm_dbus"
24PACKAGECONFIG[libibm_dbus] = " \
25 --enable-libibm_dbus, \
26 --disable-libibm_dbus, \
27 systemd sdbusplus, \
28 libsystemd sdbusplus \
29 "
30
31PACKAGECONFIG_remove_class-native = "libibm_dbus"
32PACKAGECONFIG_remove_class-nativesdk = "libibm_dbus"
33
34BBCLASSEXTEND += "native nativesdk"