blob: 34f8a7e3e5aaa28fdaa880270fcd032dddfeedea [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Dibbler DHCPv6 client"
2DESCRIPTION = "Dibbler is a portable DHCPv6 implementation. It supports stateful as well as stateless autoconfiguration for IPv6."
3HOMEPAGE = "http://klub.com.pl/dhcpv6"
4
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-2.0-only"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3"
7
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05008SRCREV = "a7c6cf58a88a510cb00841351e75030ce78d36bf"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/tomaszmrugalski/dibbler;branch=master;protocol=https \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011 file://dibbler_fix_getSize_crash.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050012 file://0001-port-linux-Re-order-header-includes.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060013 file://0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch \
14 file://0002-make-Do-not-enforce-c99.patch \
Brad Bishop19323692019-04-05 15:28:33 -040015 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016PV = "1.0.1+1.0.2RC1+git${SRCREV}"
17
18S = "${WORKDIR}/git"
19
20PACKAGECONFIG ??= "debug bind-reuse resolvconf dns-update"
21
22PACKAGECONFIG[debug] = "--enable-debug,,,"
23PACKAGECONFIG[efence] = "--enable-efence,,,"
24PACKAGECONFIG[bind-reuse] = "--enable-bind-reuse,,,"
25PACKAGECONFIG[dst-addr-filter] = "--enable-dst-addr-check,,,"
26PACKAGECONFIG[resolvconf] = "--enable-resolvconf,,,"
27PACKAGECONFIG[dns-update] = "--enable-dns-update,,,"
28PACKAGECONFIG[auth] = "--enable-auth,,,"
29PACKAGECONFIG[gtest] = "--enable-gtest-static,,,"
30
31inherit autotools
32
33DEPENDS += "flex-native"
34
Andrew Geisslerc5535c92023-01-27 16:10:19 -060035CPPFLAGS += "-D_GNU_SOURCE -Dregister=''"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050036LDFLAGS += "-pthread"
37
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038PACKAGES =+ "${PN}-requestor ${PN}-client ${PN}-relay ${PN}-server"
39
Patrick Williams213cb262021-08-07 19:21:33 -050040FILES:${PN}-client = "${sbindir}/${PN}-client"
41FILES:${PN}-relay = "${sbindir}/${PN}-relay"
42FILES:${PN}-requestor = "${sbindir}/${PN}-requestor"
43FILES:${PN}-server = "${sbindir}/${PN}-server"