blob: 6cdfef9d118e05afcb0e949281fdf5b66200c1ea [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Linux Key Management Utilities"
2DESCRIPTION = "\
3 Utilities to control the kernel key management facility and to provide \
4 a mechanism by which the kernel call back to userspace to get a key \
5 instantiated. \
6 "
7HOMEPAGE = "http://people.redhat.com/dhowells/keyutils"
8SECTION = "base"
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -040011
12LIC_FILES_CHKSUM = "file://LICENCE.GPL;md5=5f6e72824f5da505c1f4a7197f004b45 \
13 file://LICENCE.LGPL;md5=7d1cacaa3ea752b72ea5e525df54a21f"
14
Andrew Geisslerc5535c92023-01-27 16:10:19 -060015inherit manpages ptest
Brad Bishop19323692019-04-05 15:28:33 -040016
Andrew Geisslerc5535c92023-01-27 16:10:19 -060017SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git;protocol=https;branch=master \
Brad Bishop19323692019-04-05 15:28:33 -040018 file://keyutils-test-fix-output-format.patch \
19 file://keyutils-fix-error-report-by-adding-default-message.patch \
20 file://run-ptest \
Brad Bishop15ae2502019-06-18 21:44:24 -040021 file://fix_library_install_path.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060022 file://0001-tests-toolbox.inc.sh-update-regex-for-getting-endian.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060023 file://0001-Adhere-to-the-SOURCE_DATE_EPOCH-standard.patch \
24 file://0001-tests-builtin_trusted-Failure-command-is-failed.patch \
25 file://0002-tests-Use-head-n1-for-busybox-compatibility.patch \
Brad Bishop19323692019-04-05 15:28:33 -040026 "
Andrew Geisslerc5535c92023-01-27 16:10:19 -060027SRCREV = "cb3bb194cca88211cbfcdde2f10c0f43c3fb8ec3"
Brad Bishop19323692019-04-05 15:28:33 -040028
Andrew Geisslerc5535c92023-01-27 16:10:19 -060029S = "${WORKDIR}/git"
30
31PACKAGECONFIG ?= ""
32PACKAGECONFIG[manpages] = ""
Brad Bishop19323692019-04-05 15:28:33 -040033
34EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} -Wall' \
35 NO_ARLIB=1 \
36 BINDIR=${base_bindir} \
37 SBINDIR=${base_sbindir} \
Brad Bishop15ae2502019-06-18 21:44:24 -040038 LIBDIR=${libdir} \
39 USRLIBDIR=${libdir} \
40 INCLUDEDIR=${includedir} \
Andrew Geisslereff27472021-10-29 15:35:00 -050041 ETCDIR=${sysconfdir} \
42 SHAREDIR=${datadir}/keyutils \
43 MANDIR=${datadir}/man \
Brad Bishop19323692019-04-05 15:28:33 -040044 BUILDFOR=${SITEINFO_BITS}-bit \
45 NO_GLIBC_KEYERR=1 \
46 "
47
48do_install () {
Brad Bishop19323692019-04-05 15:28:33 -040049 oe_runmake DESTDIR=${D} install
50}
51
52do_install_ptest () {
53 cp -r ${S}/tests ${D}${PTEST_PATH}/
54 sed -i -e 's/OSDIST=Unknown/OSDIST=${DISTRO}/' ${D}${PTEST_PATH}/tests/prepare.inc.sh
55}
56
Brad Bishop19323692019-04-05 15:28:33 -040057
Andrew Geisslerc5535c92023-01-27 16:10:19 -060058RDEPENDS:${PN}-ptest += "bash lsb-release make"
Patrick Williams213cb262021-08-07 19:21:33 -050059RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils"
60RDEPENDS:${PN}-ptest:append:libc-musl = " musl-utils"
Brad Bishop15ae2502019-06-18 21:44:24 -040061
62BBCLASSEXTEND = "native nativesdk"