blob: cf0a60a1a92b43333422fb9c7bd4444e539f6dca [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Utility for modifying GPT disk partitioning"
2DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003HOMEPAGE = "https://sourceforge.net/projects/gptfdisk/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "GPL-2.0-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8DEPENDS = "util-linux"
9
Andrew Geissler4b740dc2020-05-05 08:54:39 -050010SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz \
11 file://0001-gptcurses-correctly-include-curses.h.patch \
Patrick Williams2390b1b2022-11-03 13:47:49 -050012 file://0001-Updated-guid.cc-to-deal-with-minor-change-in-libuuid.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060013 file://0001-Fix-failure-crash-of-sgdisk-when-compiled-with-lates.patch \
14 file://0001-Use-64bit-time_t-on-linux-as-well.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060015 file://popt-1.19-follow-up.patch \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050016 "
Patrick Williams03907ee2022-05-01 06:28:52 -050017SRC_URI[sha256sum] = "dafead2693faeb8e8b97832b23407f6ed5b3219bc1784f482dd855774e2d50c2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/gptfdisk/files/gptfdisk/"
20UPSTREAM_CHECK_REGEX = "/gptfdisk/(?P<pver>(\d+[\.\-_]*)+)/"
21
22EXTRA_OEMAKE = "'CC=${CC}' 'CXX=${CXX}' gdisk fixparts ${PACKAGECONFIG_CONFARGS}"
23
24PACKAGECONFIG ??= "ncurses popt"
25PACKAGECONFIG[ncurses] = "cgdisk,,ncurses"
26PACKAGECONFIG[popt] = "sgdisk,,popt"
27
28do_install() {
29 install -d ${D}${sbindir}
30 for f in cgdisk sgdisk; do
31 if [ -x $f ]; then
32 install -m 0755 $f ${D}${sbindir}
33 fi
34 done
35 install -m 0755 gdisk ${D}${sbindir}
36 install -m 0755 fixparts ${D}${sbindir}
37}
38
39BBCLASSEXTEND = "native nativesdk"