blob: eb3dc138a978b90d48e594c6f04ed41b3b3a33b3 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU cpio is a program to manage archives of files"
2DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \
3another. It handles a number of cpio formats as well as reading and writing tar files."
4HOMEPAGE = "http://www.gnu.org/software/cpio/"
5SECTION = "base"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-3.0-only"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
8
9SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
10 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050011 file://0002-src-global.c-Remove-superfluous-declaration-of-progr.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060012 file://0001-obstack-Fix-a-clang-warning.patch \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050013 file://CVE-2021-38185.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060014 file://0001-Use-__alignof__-with-clang.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 "
16
17SRC_URI[md5sum] = "389c5452d667c23b5eceb206f5000810"
18SRC_URI[sha256sum] = "e87470d9c984317f658567c03bfefb6b0c829ff17dbf6b0de48d71a4c8f3db88"
19
20inherit autotools gettext texinfo
21
William A. Kennington IIIac69b482021-06-02 12:28:27 -070022# Issue applies to use of cpio in SUSE/OBS, doesn't apply to us
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023CVE_CHECK_IGNORE += "CVE-2010-4226"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070024
Andrew Geissler82c905d2020-04-13 13:39:40 -050025EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
26
27do_install () {
28 autotools_do_install
29 if [ "${base_bindir}" != "${bindir}" ]; then
30 install -d ${D}${base_bindir}/
31 mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio"
Andrew Geissler475cb722020-07-10 16:00:51 -050032 if [ "${sbindir}" != "${bindir}" ]; then
33 rmdir ${D}${bindir}/
34 fi
Andrew Geissler82c905d2020-04-13 13:39:40 -050035 fi
36
37 # Avoid conflicts with the version from tar
38 mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8"
39}
40
41PACKAGES =+ "${PN}-rmt"
42
Patrick Williams213cb262021-08-07 19:21:33 -050043FILES:${PN}-rmt = "${sbindir}/rmt*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050044
45inherit update-alternatives
46
47ALTERNATIVE_PRIORITY = "100"
48
Patrick Williams213cb262021-08-07 19:21:33 -050049ALTERNATIVE:${PN} = "cpio"
50ALTERNATIVE:${PN}-rmt = "rmt"
Andrew Geissler82c905d2020-04-13 13:39:40 -050051
52ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
53
54ALTERNATIVE_PRIORITY[rmt] = "50"
55ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
56
Andrew Geissler475cb722020-07-10 16:00:51 -050057BBCLASSEXTEND = "native nativesdk"