Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU cpio is a program to manage archives of files" |
| 2 | DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \ |
| 3 | another. It handles a number of cpio formats as well as reading and writing tar files." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/cpio/" |
| 5 | SECTION = "base" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 6 | LICENSE = "GPL-3.0-only" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \ |
| 10 | file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 11 | file://0002-src-global.c-Remove-superfluous-declaration-of-progr.patch \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame^] | 12 | file://0001-obstack-Fix-a-clang-warning.patch \ |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 13 | file://CVE-2021-38185.patch \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame^] | 14 | file://0001-Use-__alignof__-with-clang.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "389c5452d667c23b5eceb206f5000810" |
| 18 | SRC_URI[sha256sum] = "e87470d9c984317f658567c03bfefb6b0c829ff17dbf6b0de48d71a4c8f3db88" |
| 19 | |
| 20 | inherit autotools gettext texinfo |
| 21 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 22 | # Issue applies to use of cpio in SUSE/OBS, doesn't apply to us |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 23 | CVE_CHECK_IGNORE += "CVE-2010-4226" |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 24 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 25 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}" |
| 26 | |
| 27 | do_install () { |
| 28 | autotools_do_install |
| 29 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 30 | install -d ${D}${base_bindir}/ |
| 31 | mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio" |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 32 | if [ "${sbindir}" != "${bindir}" ]; then |
| 33 | rmdir ${D}${bindir}/ |
| 34 | fi |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | fi |
| 36 | |
| 37 | # Avoid conflicts with the version from tar |
| 38 | mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8" |
| 39 | } |
| 40 | |
| 41 | PACKAGES =+ "${PN}-rmt" |
| 42 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | FILES:${PN}-rmt = "${sbindir}/rmt*" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | |
| 45 | inherit update-alternatives |
| 46 | |
| 47 | ALTERNATIVE_PRIORITY = "100" |
| 48 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 49 | ALTERNATIVE:${PN} = "cpio" |
| 50 | ALTERNATIVE:${PN}-rmt = "rmt" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 51 | |
| 52 | ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" |
| 53 | |
| 54 | ALTERNATIVE_PRIORITY[rmt] = "50" |
| 55 | ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt" |
| 56 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 57 | BBCLASSEXTEND = "native nativesdk" |