blob: 122c3d48b4f7cdf89b90b81657494e686ccd133e [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Userspace library to access USB (version 1.0)"
2DESCRIPTION = "A cross-platform library to access USB devices from Linux, \
3macOS, Windows, OpenBSD/NetBSD, Haiku and Solaris userspace."
4HOMEPAGE = "https://libusb.info"
5BUGTRACKER = "http://www.libusb.org/report"
6SECTION = "libs"
7
8LICENSE = "LGPL-2.1-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
10
11BBCLASSEXTEND = "native nativesdk"
12
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/libusb-${PV}.tar.bz2 \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060014 file://0001-configure.ac-Link-with-latomic-only-if-no-atomic-bui.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015 file://run-ptest \
16 "
17
Andrew Geissler87f5cff2022-09-30 13:13:31 -050018GITHUB_BASE_URI = "https://github.com/libusb/libusb/releases"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000019
Patrick Williams03907ee2022-05-01 06:28:52 -050020SRC_URI[sha256sum] = "12ce7a61fc9854d1d2a1ffe095f7b5fac19ddba095c259e6067a46500381b5a5"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000021
22S = "${WORKDIR}/libusb-${PV}"
23
Andrew Geissler87f5cff2022-09-30 13:13:31 -050024inherit autotools pkgconfig ptest github-releases
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000025
26PACKAGECONFIG:class-target ??= "udev"
27PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev"
28
29EXTRA_OECONF = "--libdir=${base_libdir}"
30
31do_install:append() {
32 install -d ${D}${libdir}
33 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
34 mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
35 fi
36}
37
Andrew Geisslerc5535c92023-01-27 16:10:19 -060038do_compile_ptest() {
39 oe_runmake -C tests stress
40}
41
42do_install_ptest() {
43 install -m 755 ${B}/tests/.libs/stress ${D}${PTEST_PATH}
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000044}
45
46FILES:${PN} += "${base_libdir}/*.so.*"
47
48FILES:${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la"