Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "GNU file archiving program" |
| 2 | DESCRIPTION = "GNU tar saves many files together into a single tape \ |
| 3 | or disk archive, and can restore individual files from the archive." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/tar/" |
| 5 | SECTION = "base" |
| 6 | LICENSE = "GPLv3" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 9 | SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 10 | |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "b44cc67f8a1f6b0250b7c860e952b37e8ed932a90bd9b1862a511079255646ff" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 12 | |
| 13 | inherit autotools gettext texinfo |
| 14 | |
| 15 | PACKAGECONFIG ??= "" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 16 | PACKAGECONFIG:append:class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 17 | |
| 18 | PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 19 | PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 20 | |
| 21 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}" |
| 22 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no" |
| 24 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 25 | # Let aclocal use the relative path for the m4 file rather than the |
| 26 | # absolute since tar has a lot of m4 files, otherwise there might |
| 27 | # be an "Argument list too long" error when it is built in a long/deep |
| 28 | # directory. |
| 29 | acpaths = "-I ./m4" |
| 30 | |
| 31 | do_install () { |
| 32 | autotools_do_install |
| 33 | ln -s tar ${D}${bindir}/gtar |
| 34 | } |
| 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | do_install:append:class-target() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 37 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 38 | install -d ${D}${base_bindir} |
| 39 | mv ${D}${bindir}/tar ${D}${base_bindir}/tar |
| 40 | mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar |
| 41 | rmdir ${D}${bindir}/ |
| 42 | fi |
| 43 | } |
| 44 | |
| 45 | PACKAGES =+ "${PN}-rmt" |
| 46 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 47 | FILES:${PN}-rmt = "${sbindir}/rmt*" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 48 | |
| 49 | inherit update-alternatives |
| 50 | |
| 51 | ALTERNATIVE_PRIORITY = "100" |
| 52 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 53 | ALTERNATIVE:${PN} = "tar" |
| 54 | ALTERNATIVE:${PN}-rmt = "rmt" |
| 55 | ALTERNATIVE:${PN}:class-nativesdk = "" |
| 56 | ALTERNATIVE:${PN}-rmt:class-nativesdk = "" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 57 | |
| 58 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" |
| 59 | ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt" |
| 60 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 61 | PROVIDES:append:class-native = " tar-replacement-native" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 62 | NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}" |
| 63 | |
| 64 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 65 | |
| 66 | # These are both specific to the NPM package node-tar |
| 67 | CVE_CHECK_WHITELIST += "CVE-2021-32803 CVE-2021-32804" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 68 | CVE_CHECK_WHITELIST += "CVE-2021-37701 CVE-2021-37712 CVE-2021-37713" |