blob: cb18667755404ac1ad1a0fb03e63f94a7aade373 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "rsync is an open source utility that provides fast incremental file transfer."
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
5SECTION = "console/network"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
Andrew Geissler475cb722020-07-10 16:00:51 -05007# Includes opennsh and xxhash dynamic link exception
Brad Bishop316dfdd2018-06-25 12:45:53 -04008LICENSE = "GPLv3+"
Andrew Geissler475cb722020-07-10 16:00:51 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=9e5a4f9b3a253d51520617aa54f8eb26"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011DEPENDS = "popt"
12
13SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
14 file://rsyncd.conf \
15 file://makefile-no-rebuild.patch \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060016 file://determism.patch \
Andrew Geisslerc926e172021-05-07 16:11:35 -050017 file://0001-rsync-ssl-Verify-the-hostname-in-the-certificate-whe.patch \
Andrew Geissler475cb722020-07-10 16:00:51 -050018 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
Andrew Geisslerc9f78652020-09-18 14:11:35 -050020SRC_URI[sha256sum] = "becc3c504ceea499f4167a260040ccf4d9f2ef9499ad5683c179a697146ce50e"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
Andrew Geissler82c905d2020-04-13 13:39:40 -050022# -16548 required for v3.1.3pre1. Already in v3.1.3.
23CVE_CHECK_WHITELIST += " CVE-2017-16548 "
24
Andrew Geissler475cb722020-07-10 16:00:51 -050025inherit autotools-brokensep
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026
Brad Bishop316dfdd2018-06-25 12:45:53 -040027PACKAGECONFIG ??= "acl attr \
28 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
29"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
Brad Bishop316dfdd2018-06-25 12:45:53 -040031PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
32PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Andrew Geissler475cb722020-07-10 16:00:51 -050034PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
35PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
36PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash"
37PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
Brad Bishop316dfdd2018-06-25 12:45:53 -040038
39# By default, if crosscompiling, rsync disables a number of
40# capabilities, hardlinking symlinks and special files (i.e. devices)
41CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
42
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080043EXTRA_OEMAKE = 'STRIP=""'
Andrew Geissler90fd73c2021-03-05 15:25:55 -060044EXTRA_OECONF = "--disable-simd --disable-md2man --disable-asm --with-nobody-group=nogroup"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045
Brad Bishop316dfdd2018-06-25 12:45:53 -040046# rsync 3.0 uses configure.sh instead of configure, and
47# makefile checks the existence of configure.sh
48do_configure_prepend () {
49 rm -f ${S}/configure ${S}/configure.sh
50}
51
52do_configure_append () {
53 cp -f ${S}/configure ${S}/configure.sh
54}
55
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080056do_install_append() {
57 install -d ${D}${sysconfdir}
58 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
59}
60
Andrew Geissler6ce62a22020-11-30 19:58:47 -060061BBCLASSEXTEND = "native nativesdk"