blob: aa279bb503568bcdcfdb0038d4d76a3b60cb3ee5 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
Andrew Geissler09209ee2020-12-13 08:44:15 -060018GIR_MESON_ENABLE_FLAG = "enabled"
19GIR_MESON_DISABLE_FLAG = "disabled"
20
Andrew Geisslerc926e172021-05-07 16:11:35 -050021SRC_URI += "file://run-ptest"
22
Andrew Geissler90fd73c2021-03-05 15:25:55 -060023SRC_URI[archive.sha256sum] = "d21f8b30dc8abdfc55de25656ecb88dc1105eeeb315e5e2a980dcef8010c2c80"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
26
27PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
28 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
29
30PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
31PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
32PACKAGECONFIG[thai] = ",,libthai"
33
34GTKDOC_MESON_OPTION = "gtk_doc"
35GIR_MESON_OPTION = 'introspection'
36
Andrew Geissler09209ee2020-12-13 08:44:15 -060037do_configure_prepend() {
38 chmod +x ${S}/tests/*.py
39}
40
Andrew Geissler82c905d2020-04-13 13:39:40 -050041do_configure_prepend_toolchain-clang() {
42 sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build
43}
44
45LEAD_SONAME = "libpango-1.0*"
46
47FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
48
49RDEPENDS_${PN}-ptest += "cantarell-fonts"
50RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
51
52RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
53 pango-module-basic-fc pango-module-arabic-lang"
54
55BBCLASSEXTEND = "native nativesdk"