blob: 6c8bedcd65adcefde9df4633b15f998b71a4185b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Copyright (C) 2013 Intel Corporation
2#
3# Released under the MIT license (see COPYING.MIT)
4
Brad Bishopf86d0552018-12-04 14:18:15 -08005inherit metadata_scm
Andrew Geisslerc9f78652020-09-18 14:11:35 -05006inherit image-artifact-names
7
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008# testimage.bbclass enables testing of qemu images using python unittests.
9# Most of the tests are commands run on target image over ssh.
10# To use it add testimage to global inherit and call your target image with -c testimage
11# You can try it out like this:
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012# - first add IMAGE_CLASSES += "testimage" in local.conf
13# - build a qemu core-image-sato
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014# - then bitbake core-image-sato -c testimage. That will run a standard suite of tests.
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015#
16# The tests can be run automatically each time an image is built if you set
17# TESTIMAGE_AUTO = "1"
18
19TESTIMAGE_AUTO ??= "0"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
21# You can set (or append to) TEST_SUITES in local.conf to select the tests
22# which you want to run for your target.
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023# The test names are the module names in meta/lib/oeqa/runtime/cases.
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024# Each name in TEST_SUITES represents a required test for the image. (no skipping allowed)
25# Appending "auto" means that it will try to run all tests that are suitable for the image (each test decides that on it's own).
26# Note that order in TEST_SUITES is relevant: tests are run in an order such that
27# tests mentioned in @skipUnlessPassed run before the tests that depend on them,
28# but without such dependencies, tests run in the order in which they are listed
29# in TEST_SUITES.
30#
31# A layer can add its own tests in lib/oeqa/runtime, provided it extends BBPATH as normal in its layer.conf.
32
33# TEST_LOG_DIR contains a command ssh log and may contain infromation about what command is running, output and return codes and for qemu a boot log till login.
34# Booting is handled by this class, and it's not a test in itself.
35# TEST_QEMUBOOT_TIMEOUT can be used to set the maximum time in seconds the launch code will wait for the login prompt.
Andrew Geissler82c905d2020-04-13 13:39:40 -050036# TEST_OVERALL_TIMEOUT can be used to set the maximum time in seconds the tests will be allowed to run (defaults to no limit).
Brad Bishop977dc1a2019-02-06 16:01:43 -050037# TEST_QEMUPARAMS can be used to pass extra parameters to qemu, e.g. "-m 1024" for setting the amount of ram to 1 GB.
Brad Bishop19323692019-04-05 15:28:33 -040038# TEST_RUNQEMUPARAMS can be used to pass extra parameters to runqemu, e.g. "gl" to enable OpenGL acceleration.
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039
Andrew Geissler82c905d2020-04-13 13:39:40 -050040# TESTIMAGE_BOOT_PATTERNS can be used to override certain patterns used to communicate with the target when booting,
41# if a pattern is not specifically present on this variable a default will be used when booting the target.
42# TESTIMAGE_BOOT_PATTERNS[<flag>] overrides the pattern used for that specific flag, where flag comes from a list of accepted flags
43# e.g. normally the system boots and waits for a login prompt (login:), after that it sends the command: "root\n" to log as the root user
44# if we wanted to log in as the hypothetical "webserver" user for example we could set the following:
45# TESTIMAGE_BOOT_PATTERNS = "send_login_user search_login_succeeded"
46# TESTIMAGE_BOOT_PATTERNS[send_login_user] = "webserver\n"
47# TESTIMAGE_BOOT_PATTERNS[search_login_succeeded] = "webserver@[a-zA-Z0-9\-]+:~#"
48# The accepted flags are the following: search_reached_prompt, send_login_user, search_login_succeeded, search_cmd_finished.
49# They are prefixed with either search/send, to differentiate if the pattern is meant to be sent or searched to/from the target terminal
50
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051TEST_LOG_DIR ?= "${WORKDIR}/testimage"
52
53TEST_EXPORT_DIR ?= "${TMPDIR}/testimage/${PN}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060054TEST_INSTALL_TMP_DIR ?= "${WORKDIR}/testimage/install_tmp"
55TEST_NEEDED_PACKAGES_DIR ?= "${WORKDIR}/testimage/packages"
56TEST_EXTRACTED_DIR ?= "${TEST_NEEDED_PACKAGES_DIR}/extracted"
57TEST_PACKAGED_DIR ?= "${TEST_NEEDED_PACKAGES_DIR}/packaged"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058
Brad Bishop977dc1a2019-02-06 16:01:43 -050059BASICTESTSUITE = "\
60 ping date df ssh scp python perl gi ptest parselogs \
61 logrotate connman systemd oe_syslog pam stap ldd xorg \
62 kernelmodule gcc buildcpio buildlzip buildgalculator \
Andrew Geissler82c905d2020-04-13 13:39:40 -050063 dnf rpm opkg apt weston"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050064
Brad Bishop977dc1a2019-02-06 16:01:43 -050065DEFAULT_TEST_SUITES = "${BASICTESTSUITE}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050066
67# aarch64 has no graphics
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050068DEFAULT_TEST_SUITES_remove_aarch64 = "xorg"
Brad Bishop316dfdd2018-06-25 12:45:53 -040069# musl doesn't support systemtap
70DEFAULT_TEST_SUITES_remove_libc-musl = "stap"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050071
Patrick Williamsc0f7c042017-02-23 20:41:17 -060072# qemumips is quite slow and has reached the timeout limit several times on the YP build cluster,
73# mitigate this by removing build tests for qemumips machines.
Brad Bishopd7bf8c12018-02-25 22:55:05 -050074MIPSREMOVE ??= "buildcpio buildlzip buildgalculator"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060075DEFAULT_TEST_SUITES_remove_qemumips = "${MIPSREMOVE}"
76DEFAULT_TEST_SUITES_remove_qemumips64 = "${MIPSREMOVE}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050077
78TEST_SUITES ?= "${DEFAULT_TEST_SUITES}"
79
80TEST_QEMUBOOT_TIMEOUT ?= "1000"
Andrew Geissler82c905d2020-04-13 13:39:40 -050081TEST_OVERALL_TIMEOUT ?= ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050082TEST_TARGET ?= "qemu"
Brad Bishop977dc1a2019-02-06 16:01:43 -050083TEST_QEMUPARAMS ?= ""
Brad Bishop19323692019-04-05 15:28:33 -040084TEST_RUNQEMUPARAMS ?= ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050085
Andrew Geissler82c905d2020-04-13 13:39:40 -050086TESTIMAGE_BOOT_PATTERNS ?= ""
87
Patrick Williamsc124f4f2015-09-15 14:41:29 -050088TESTIMAGEDEPENDS = ""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080089TESTIMAGEDEPENDS_append_qemuall = " qemu-native:do_populate_sysroot qemu-helper-native:do_populate_sysroot qemu-helper-native:do_addto_recipe_sysroot"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060090TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'cpio-native:do_populate_sysroot', '', d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050091TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'dnf-native:do_populate_sysroot', '', d)}"
Brad Bishop977dc1a2019-02-06 16:01:43 -050092TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'createrepo-c-native:do_populate_sysroot', '', d)}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080093TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'ipk', 'opkg-utils-native:do_populate_sysroot package-index:do_package_index', '', d)}"
94TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'deb', 'apt-native:do_populate_sysroot package-index:do_package_index', '', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050095
96TESTIMAGELOCK = "${TMPDIR}/testimage.lock"
97TESTIMAGELOCK_qemuall = ""
98
Brad Bishop977dc1a2019-02-06 16:01:43 -050099TESTIMAGE_DUMP_DIR ?= "${LOG_DIR}/runtime-hostdump/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500100
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500101TESTIMAGE_UPDATE_VARS ?= "DL_DIR WORKDIR DEPLOY_DIR"
102
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500103testimage_dump_target () {
104 top -bn1
105 ps
106 free
107 df
108 # The next command will export the default gateway IP
109 export DEFAULT_GATEWAY=$(ip route | awk '/default/ { print $3}')
110 ping -c3 $DEFAULT_GATEWAY
111 dmesg
112 netstat -an
113 ip address
114 # Next command will dump logs from /var/log/
115 find /var/log/ -type f 2>/dev/null -exec echo "====================" \; -exec echo {} \; -exec echo "====================" \; -exec cat {} \; -exec echo "" \;
116}
117
118testimage_dump_host () {
119 top -bn1
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500120 iostat -x -z -N -d -p ALL 20 2
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500121 ps -ef
122 free
123 df
124 memstat
125 dmesg
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500126 ip -s link
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500127 netstat -an
128}
129
130python do_testimage() {
131 testimage_main(d)
132}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600133
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500134addtask testimage
135do_testimage[nostamp] = "1"
136do_testimage[depends] += "${TESTIMAGEDEPENDS}"
137do_testimage[lockfiles] += "${TESTIMAGELOCK}"
138
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500139def testimage_sanity(d):
140 if (d.getVar('TEST_TARGET') == 'simpleremote'
141 and (not d.getVar('TEST_TARGET_IP')
142 or not d.getVar('TEST_SERVER_IP'))):
143 bb.fatal('When TEST_TARGET is set to "simpleremote" '
144 'TEST_TARGET_IP and TEST_SERVER_IP are needed too.')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500145
Brad Bishopf86d0552018-12-04 14:18:15 -0800146def get_testimage_configuration(d, test_type, machine):
147 import platform
148 from oeqa.utils.metadata import get_layers
149 configuration = {'TEST_TYPE': test_type,
150 'MACHINE': machine,
151 'DISTRO': d.getVar("DISTRO"),
152 'IMAGE_BASENAME': d.getVar("IMAGE_BASENAME"),
153 'IMAGE_PKGTYPE': d.getVar("IMAGE_PKGTYPE"),
154 'STARTTIME': d.getVar("DATETIME"),
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800155 'HOST_DISTRO': oe.lsb.distro_identifier().replace(' ', '-'),
Brad Bishopf86d0552018-12-04 14:18:15 -0800156 'LAYERS': get_layers(d.getVar("BBLAYERS"))}
157 return configuration
158get_testimage_configuration[vardepsexclude] = "DATETIME"
159
160def get_testimage_json_result_dir(d):
161 json_result_dir = os.path.join(d.getVar("LOG_DIR"), 'oeqa')
162 custom_json_result_dir = d.getVar("OEQA_JSON_RESULT_DIR")
163 if custom_json_result_dir:
164 json_result_dir = custom_json_result_dir
165 return json_result_dir
166
167def get_testimage_result_id(configuration):
168 return '%s_%s_%s_%s' % (configuration['TEST_TYPE'], configuration['IMAGE_BASENAME'], configuration['MACHINE'], configuration['STARTTIME'])
169
Andrew Geissler82c905d2020-04-13 13:39:40 -0500170def get_testimage_boot_patterns(d):
171 from collections import defaultdict
172 boot_patterns = defaultdict(str)
173 # Only accept certain values
174 accepted_patterns = ['search_reached_prompt', 'send_login_user', 'search_login_succeeded', 'search_cmd_finished']
175 # Not all patterns need to be overriden, e.g. perhaps we only want to change the user
176 boot_patterns_flags = d.getVarFlags('TESTIMAGE_BOOT_PATTERNS') or {}
177 if boot_patterns_flags:
178 patterns_set = [p for p in boot_patterns_flags.items() if p[0] in d.getVar('TESTIMAGE_BOOT_PATTERNS').split()]
179 for flag, flagval in patterns_set:
180 if flag not in accepted_patterns:
181 bb.fatal('Testimage: The only accepted boot patterns are: search_reached_prompt,send_login_user, \
182 search_login_succeeded,search_cmd_finished\n Make sure your TESTIMAGE_BOOT_PATTERNS=%s \
183 contains an accepted flag.' % d.getVar('TESTIMAGE_BOOT_PATTERNS'))
184 return
185 # We know boot prompt is searched through in binary format, others might be expressions
186 if flag == 'search_reached_prompt':
187 boot_patterns[flag] = flagval.encode()
188 else:
189 boot_patterns[flag] = flagval.encode().decode('unicode-escape')
190 return boot_patterns
191
192
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500193def testimage_main(d):
194 import os
195 import json
196 import signal
197 import logging
198
199 from bb.utils import export_proxies
200 from oeqa.core.utils.misc import updateTestData
201 from oeqa.runtime.context import OERuntimeTestContext
202 from oeqa.runtime.context import OERuntimeTestContextExecutor
203 from oeqa.core.target.qemu import supported_fstypes
204 from oeqa.core.utils.test import getSuiteCases
205 from oeqa.utils import make_logger_bitbake_compatible
206
207 def sigterm_exception(signum, stackframe):
208 """
209 Catch SIGTERM from worker in order to stop qemu.
210 """
Andrew Geissler82c905d2020-04-13 13:39:40 -0500211 os.kill(os.getpid(), signal.SIGINT)
212
213 def handle_test_timeout(timeout):
214 bb.warn("Global test timeout reached (%s seconds), stopping the tests." %(timeout))
215 os.kill(os.getpid(), signal.SIGINT)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500216
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700217 testimage_sanity(d)
218
219 if (d.getVar('IMAGE_PKGTYPE') == 'rpm'
220 and ('dnf' in d.getVar('TEST_SUITES') or 'auto' in d.getVar('TEST_SUITES'))):
221 create_rpm_index(d)
222
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500223 logger = make_logger_bitbake_compatible(logging.getLogger("BitBake"))
224 pn = d.getVar("PN")
225
226 bb.utils.mkdirhier(d.getVar("TEST_LOG_DIR"))
227
228 image_name = ("%s/%s" % (d.getVar('DEPLOY_DIR_IMAGE'),
229 d.getVar('IMAGE_LINK_NAME')))
230
231 tdname = "%s.testdata.json" % image_name
232 try:
233 td = json.load(open(tdname, "r"))
234 except (FileNotFoundError) as err:
235 bb.fatal('File %s Not Found. Have you built the image with INHERIT+="testimage" in the conf/local.conf?' % tdname)
236
237 # Some variables need to be updates (mostly paths) with the
238 # ones of the current environment because some tests require them.
239 updateTestData(d, td, d.getVar('TESTIMAGE_UPDATE_VARS').split())
240
241 image_manifest = "%s.manifest" % image_name
242 image_packages = OERuntimeTestContextExecutor.readPackagesManifest(image_manifest)
243
244 extract_dir = d.getVar("TEST_EXTRACTED_DIR")
245
246 # Get machine
247 machine = d.getVar("MACHINE")
248
249 # Get rootfs
Brad Bishop977dc1a2019-02-06 16:01:43 -0500250 fstypes = d.getVar('IMAGE_FSTYPES').split()
251 if d.getVar("TEST_TARGET") == "qemu":
252 fstypes = [fs for fs in fstypes if fs in supported_fstypes]
253 if not fstypes:
Andrew Geissler82c905d2020-04-13 13:39:40 -0500254 bb.fatal('Unsupported image type built. Add a compatible image to '
Brad Bishop977dc1a2019-02-06 16:01:43 -0500255 'IMAGE_FSTYPES. Supported types: %s' %
256 ', '.join(supported_fstypes))
Brad Bishop15ae2502019-06-18 21:44:24 -0400257 qfstype = fstypes[0]
258 qdeffstype = d.getVar("QB_DEFAULT_FSTYPE")
259 if qdeffstype:
260 qfstype = qdeffstype
261 rootfs = '%s.%s' % (image_name, qfstype)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500262
263 # Get tmpdir (not really used, just for compatibility)
264 tmpdir = d.getVar("TMPDIR")
265
266 # Get deploy_dir_image (not really used, just for compatibility)
267 dir_image = d.getVar("DEPLOY_DIR_IMAGE")
268
269 # Get bootlog
270 bootlog = os.path.join(d.getVar("TEST_LOG_DIR"),
271 'qemu_boot_log.%s' % d.getVar('DATETIME'))
272
273 # Get display
274 display = d.getVar("BB_ORIGENV").getVar("DISPLAY")
275
276 # Get kernel
277 kernel_name = ('%s-%s.bin' % (d.getVar("KERNEL_IMAGETYPE"), machine))
278 kernel = os.path.join(d.getVar("DEPLOY_DIR_IMAGE"), kernel_name)
279
280 # Get boottime
281 boottime = int(d.getVar("TEST_QEMUBOOT_TIMEOUT"))
282
283 # Get use_kvm
Brad Bishop977dc1a2019-02-06 16:01:43 -0500284 kvm = oe.types.qemu_use_kvm(d.getVar('QEMU_USE_KVM'), d.getVar('TARGET_ARCH'))
285
Andrew Geissler82c905d2020-04-13 13:39:40 -0500286 # Get OVMF
287 ovmf = d.getVar("QEMU_USE_OVMF")
288
Brad Bishop977dc1a2019-02-06 16:01:43 -0500289 slirp = False
290 if d.getVar("QEMU_USE_SLIRP"):
291 slirp = True
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500292
Andrew Geissler82c905d2020-04-13 13:39:40 -0500293 # TODO: We use the current implementation of qemu runner because of
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500294 # time constrains, qemu runner really needs a refactor too.
295 target_kwargs = { 'machine' : machine,
296 'rootfs' : rootfs,
297 'tmpdir' : tmpdir,
298 'dir_image' : dir_image,
299 'display' : display,
300 'kernel' : kernel,
301 'boottime' : boottime,
302 'bootlog' : bootlog,
303 'kvm' : kvm,
Brad Bishop977dc1a2019-02-06 16:01:43 -0500304 'slirp' : slirp,
305 'dump_dir' : d.getVar("TESTIMAGE_DUMP_DIR"),
Andrew Geissler82c905d2020-04-13 13:39:40 -0500306 'serial_ports': len(d.getVar("SERIAL_CONSOLES").split()),
307 'ovmf' : ovmf,
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500308 }
309
Andrew Geissler82c905d2020-04-13 13:39:40 -0500310 if d.getVar("TESTIMAGE_BOOT_PATTERNS"):
311 target_kwargs['boot_patterns'] = get_testimage_boot_patterns(d)
312
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500313 # TODO: Currently BBPATH is needed for custom loading of targets.
314 # It would be better to find these modules using instrospection.
315 target_kwargs['target_modules_path'] = d.getVar('BBPATH')
316
Brad Bishop64c979e2019-11-04 13:55:29 -0500317 # hardware controlled targets might need further access
318 target_kwargs['powercontrol_cmd'] = d.getVar("TEST_POWERCONTROL_CMD") or None
319 target_kwargs['powercontrol_extra_args'] = d.getVar("TEST_POWERCONTROL_EXTRA_ARGS") or ""
320 target_kwargs['serialcontrol_cmd'] = d.getVar("TEST_SERIALCONTROL_CMD") or None
321 target_kwargs['serialcontrol_extra_args'] = d.getVar("TEST_SERIALCONTROL_EXTRA_ARGS") or ""
322
323 def export_ssh_agent(d):
324 import os
325
326 variables = ['SSH_AGENT_PID', 'SSH_AUTH_SOCK']
327 for v in variables:
328 if v not in os.environ.keys():
329 val = d.getVar(v)
330 if val is not None:
331 os.environ[v] = val
332
333 export_ssh_agent(d)
334
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500335 # runtime use network for download projects for build
336 export_proxies(d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500337
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500338 # we need the host dumper in test context
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500339 host_dumper = OERuntimeTestContextExecutor.getHostDumper(
340 d.getVar("testimage_dump_host"),
341 d.getVar("TESTIMAGE_DUMP_DIR"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500342
343 # the robot dance
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500344 target = OERuntimeTestContextExecutor.getTarget(
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500345 d.getVar("TEST_TARGET"), logger, d.getVar("TEST_TARGET_IP"),
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500346 d.getVar("TEST_SERVER_IP"), **target_kwargs)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500347
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500348 # test context
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500349 tc = OERuntimeTestContext(td, logger, target, host_dumper,
350 image_packages, extract_dir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500351
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500352 # Load tests before starting the target
353 test_paths = get_runtime_paths(d)
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500354 test_modules = d.getVar('TEST_SUITES').split()
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700355 if not test_modules:
356 bb.fatal('Empty test suite, please verify TEST_SUITES variable')
357
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500358 tc.loadTests(test_paths, modules=test_modules)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500359
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700360 suitecases = getSuiteCases(tc.suites)
361 if not suitecases:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500362 bb.fatal('Empty test suite, please verify TEST_SUITES variable')
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700363 else:
364 bb.debug(2, 'test suites:\n\t%s' % '\n\t'.join([str(c) for c in suitecases]))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500365
366 package_extraction(d, tc.suites)
367
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500368 results = None
369 orig_sigterm_handler = signal.signal(signal.SIGTERM, sigterm_exception)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600370 try:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500371 # We need to check if runqemu ends unexpectedly
372 # or if the worker send us a SIGTERM
Brad Bishop19323692019-04-05 15:28:33 -0400373 tc.target.start(params=d.getVar("TEST_QEMUPARAMS"), runqemuparams=d.getVar("TEST_RUNQEMUPARAMS"))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500374 import threading
375 try:
376 threading.Timer(int(d.getVar("TEST_OVERALL_TIMEOUT")), handle_test_timeout, (int(d.getVar("TEST_OVERALL_TIMEOUT")),)).start()
377 except ValueError:
378 pass
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500379 results = tc.runTests()
Andrew Geissler82c905d2020-04-13 13:39:40 -0500380 except (KeyboardInterrupt, BlockingIOError) as err:
381 if isinstance(err, KeyboardInterrupt):
382 bb.error('testimage interrupted, shutting down...')
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600383 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500384 bb.error('runqemu failed, shutting down...')
385 if results:
386 results.stop()
387 results = None
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600388 finally:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500389 signal.signal(signal.SIGTERM, orig_sigterm_handler)
390 tc.target.stop()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600391
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500392 # Show results (if we have them)
393 if not results:
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500394 bb.fatal('%s - FAILED - tests were interrupted during execution' % pn, forcelog=True)
Brad Bishopf86d0552018-12-04 14:18:15 -0800395 configuration = get_testimage_configuration(d, 'runtime', machine)
396 results.logDetails(get_testimage_json_result_dir(d),
397 configuration,
Brad Bishopc342db32019-05-15 21:57:59 -0400398 get_testimage_result_id(configuration),
399 dump_streams=d.getVar('TESTREPORT_FULLLOGS'))
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500400 results.logSummary(pn)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500401 if not results.wasSuccessful():
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500402 bb.fatal('%s - FAILED - check the task log and the ssh log' % pn, forcelog=True)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600403
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500404def get_runtime_paths(d):
405 """
406 Returns a list of paths where runtime test must reside.
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500407
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500408 Runtime tests are expected in <LAYER_DIR>/lib/oeqa/runtime/cases/
409 """
410 paths = []
411
412 for layer in d.getVar('BBLAYERS').split():
413 path = os.path.join(layer, 'lib/oeqa/runtime/cases')
414 if os.path.isdir(path):
415 paths.append(path)
416 return paths
417
418def create_index(arg):
419 import subprocess
420
421 index_cmd = arg
422 try:
423 bb.note("Executing '%s' ..." % index_cmd)
424 result = subprocess.check_output(index_cmd,
425 stderr=subprocess.STDOUT,
426 shell=True)
427 result = result.decode('utf-8')
428 except subprocess.CalledProcessError as e:
429 return("Index creation command '%s' failed with return code "
430 '%d:\n%s' % (e.cmd, e.returncode, e.output.decode("utf-8")))
431 if result:
432 bb.note(result)
433 return None
434
435def create_rpm_index(d):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800436 import glob
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500437 # Index RPMs
438 rpm_createrepo = bb.utils.which(os.getenv('PATH'), "createrepo_c")
439 index_cmds = []
440 archs = (d.getVar('ALL_MULTILIB_PACKAGE_ARCHS') or '').replace('-', '_')
441
442 for arch in archs.split():
443 rpm_dir = os.path.join(d.getVar('DEPLOY_DIR_RPM'), arch)
444 idx_path = os.path.join(d.getVar('WORKDIR'), 'oe-testimage-repo', arch)
445
446 if not os.path.isdir(rpm_dir):
447 continue
448
449 lockfilename = os.path.join(d.getVar('DEPLOY_DIR_RPM'), 'rpm.lock')
450 lf = bb.utils.lockfile(lockfilename, False)
451 oe.path.copyhardlinktree(rpm_dir, idx_path)
452 # Full indexes overload a 256MB image so reduce the number of rpms
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800453 # in the feed by filtering to specific packages needed by the tests.
454 package_list = glob.glob(idx_path + "*/*.rpm")
455
456 for pkg in package_list:
457 if not os.path.basename(pkg).startswith(("rpm", "run-postinsts", "busybox", "bash", "update-alternatives", "libc6", "curl", "musl")):
458 bb.utils.remove(pkg)
459
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500460 bb.utils.unlockfile(lf)
461 cmd = '%s --update -q %s' % (rpm_createrepo, idx_path)
462
463 # Create repodata
464 result = create_index(cmd)
465 if result:
466 bb.fatal('%s' % ('\n'.join(result)))
467
468def package_extraction(d, test_suites):
469 from oeqa.utils.package_manager import find_packages_to_extract
470 from oeqa.utils.package_manager import extract_packages
471
472 bb.utils.remove(d.getVar("TEST_NEEDED_PACKAGES_DIR"), recurse=True)
473 packages = find_packages_to_extract(test_suites)
474 if packages:
475 bb.utils.mkdirhier(d.getVar("TEST_INSTALL_TMP_DIR"))
476 bb.utils.mkdirhier(d.getVar("TEST_PACKAGED_DIR"))
477 bb.utils.mkdirhier(d.getVar("TEST_EXTRACTED_DIR"))
478 extract_packages(d, packages)
479
480testimage_main[vardepsexclude] += "BB_ORIGENV DATETIME"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500481
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800482python () {
483 if oe.types.boolean(d.getVar("TESTIMAGE_AUTO") or "False"):
484 bb.build.addtask("testimage", "do_build", "do_image_complete", d)
485}
486
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500487inherit testsdk