blob: 613e3161fb9bfcce8ae7a4e833a016b86cace699 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "U-Boot libraries and tools to access environment"
Andrew Geissler82c905d2020-04-13 13:39:40 -05002
3DESCRIPTION = "This package contains tools and libraries to read \
4and modify U-Boot environment. \
5It provides a hardware-independent replacement for fw_printenv/setenv utilities \
6provided by U-Boot"
7
8HOMEPAGE = "https://github.com/sbabic/libubootenv"
9LICENSE = "LGPL-2.1"
10LIC_FILES_CHKSUM = "file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c"
11SECTION = "libs"
12
Andrew Geissler82c905d2020-04-13 13:39:40 -050013SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050014SRCREV = "824551ac77bab1d0f7ae34d7a7c77b155240e754"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16S = "${WORKDIR}/git"
17
Andrew Geisslerc9f78652020-09-18 14:11:35 -050018inherit uboot-config cmake lib_package
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
21
Andrew Geissler4ed12e12020-06-05 18:00:41 -050022DEPENDS = "zlib"
Andrew Geissler82c905d2020-04-13 13:39:40 -050023PROVIDES += "u-boot-fw-utils"
24RPROVIDES_${PN}-bin += "u-boot-fw-utils"
25
Andrew Geissler635e0e42020-08-21 15:58:33 -050026PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28RRECOMMENDS_${PN}-bin_append_class-target = " u-boot-default-env"
29
Andrew Geissler82c905d2020-04-13 13:39:40 -050030BBCLASSEXTEND = "native"