blob: 8945831737058767944c180071f952a936463f0a [file] [log] [blame]
Kuiying Wang91ff72a2018-11-08 16:52:49 +08001SUMMARY = "OpenBMC Buttons"
2DESCRIPTION = "OpenBMC All buttons"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8S = "${WORKDIR}/git"
9SRC_URI += "git://github.com/openbmc/phosphor-buttons.git"
Andrew Geissler22040562020-02-24 01:31:02 +000010SRCREV = "582b3f025a0ca424d07aee67185d51915bdf2f46"
Kuiying Wang91ff72a2018-11-08 16:52:49 +080011
12inherit cmake pkgconfig systemd
13
Matt Spinler9ad66412018-11-26 15:37:30 -060014BUTTON_PACKAGES="${PN}-signals ${PN}-handler"
15
16ALLOW_EMPTY_${PN} = "1"
17PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"
18PACKAGECONFIG ??= "signals handler"
19SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
20
21PACKAGECONFIG[signals] = ",,gpioplus nlohmann-json,"
22PACKAGECONFIG[handler] = ",,,phosphor-state-manager-chassis phosphor-state-manager-host"
23
Patrick Venture35563f42019-04-01 10:20:46 -070024FILES_${PN}-signals = "${bindir}/buttons"
Matt Spinler9ad66412018-11-26 15:37:30 -060025SYSTEMD_SERVICE_${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service"
26
Patrick Venture35563f42019-04-01 10:20:46 -070027FILES_${PN}-handler = "${bindir}/button-handler"
Matt Spinler9ad66412018-11-26 15:37:30 -060028SYSTEMD_SERVICE_${PN}-handler = "phosphor-button-handler.service"
Kuiying Wang91ff72a2018-11-08 16:52:49 +080029
30DEPENDS += " \
31 systemd \
32 sdbusplus \
33 phosphor-dbus-interfaces \
34 phosphor-logging \
Kuiying Wang91ff72a2018-11-08 16:52:49 +080035 "