Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager." |
| 2 | SUMMARY = "EFI Boot Manager" |
| 3 | HOMEPAGE = "https://github.com/rhboot/efibootmgr" |
| 4 | SECTION = "base" |
| 5 | |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
| 8 | |
| 9 | DEPENDS = "efivar popt" |
| 10 | |
| 11 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 12 | |
| 13 | SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \ |
| 14 | file://0001-remove-extra-decl.patch \ |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 15 | file://97668ae0bce776a36ea2001dea63d376be8274ac.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 16 | " |
| 17 | SRCREV = "e067160ecef8208e1944002e5d50b275733211fb" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit pkgconfig |
| 22 | |
| 23 | # The directory under the ESP that the default bootloader is found in. When |
| 24 | # wic uses a subdirectory, this should use the same one too. |
| 25 | EFIDIR ?= "/" |
| 26 | |
| 27 | EXTRA_OEMAKE += "'EFIDIR=${EFIDIR}'" |
| 28 | |
| 29 | CFLAGS += " -Wno-error" |
| 30 | |
| 31 | do_install () { |
| 32 | oe_runmake install DESTDIR="${D}" |
| 33 | } |
| 34 | |
| 35 | CLEANBROKEN = "1" |