blob: 54e169768c4a64665f8b0798eb60fb0115e380df [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
William A. Kennington IIIac69b482021-06-02 12:28:27 -070016inherit gnomebase gi-docgen ptest-gnome upstream-version-is-even gobject-introspection
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
Andrew Geissler09209ee2020-12-13 08:44:15 -060018GIR_MESON_ENABLE_FLAG = "enabled"
19GIR_MESON_DISABLE_FLAG = "disabled"
20
Andrew Geisslerc926e172021-05-07 16:11:35 -050021SRC_URI += "file://run-ptest"
22
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050023SRC_URI[archive.sha256sum] = "a913657d3fe5aa04c03958a3b5d3fc859e891b75cd81b873a819330f6c0872aa"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
26
27PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
28 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
29
30PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
31PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
32PACKAGECONFIG[thai] = ",,libthai"
33
Andrew Geissler82c905d2020-04-13 13:39:40 -050034GIR_MESON_OPTION = 'introspection'
35
Patrick Williams213cb262021-08-07 19:21:33 -050036do_configure:prepend() {
Andrew Geissler09209ee2020-12-13 08:44:15 -060037 chmod +x ${S}/tests/*.py
38}
39
Patrick Williams213cb262021-08-07 19:21:33 -050040do_configure:prepend:toolchain-clang() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050041 sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build
42}
43
44LEAD_SONAME = "libpango-1.0*"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046FILES:${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050047
Patrick Williams213cb262021-08-07 19:21:33 -050048RDEPENDS:${PN}-ptest += "cantarell-fonts"
49RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
Andrew Geissler82c905d2020-04-13 13:39:40 -050050
Patrick Williams213cb262021-08-07 19:21:33 -050051RPROVIDES:${PN} += "pango-modules pango-module-indic-lang \
Andrew Geissler82c905d2020-04-13 13:39:40 -050052 pango-module-basic-fc pango-module-arabic-lang"
53
54BBCLASSEXTEND = "native nativesdk"