Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | require grub2.inc |
| 2 | |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 3 | require conf/image-uefi.conf |
| 4 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | GRUBPLATFORM = "efi" |
| 6 | |
Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame^] | 7 | DEPENDS_append = " grub-native" |
| 8 | RDEPENDS_${PN} = "grub-common virtual/grub-bootconf" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://cfg \ |
| 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}/grub-${PV}" |
| 15 | |
| 16 | # Determine the target arch for the grub modules |
| 17 | python __anonymous () { |
| 18 | import re |
| 19 | target = d.getVar('TARGET_ARCH') |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 20 | prefix = "" if d.getVar('EFI_PROVIDER') == "grub-efi" else "grub-efi-" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 21 | if target == "x86_64": |
| 22 | grubtarget = 'x86_64' |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 23 | elif re.match('i.86', target): |
| 24 | grubtarget = 'i386' |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 25 | elif re.match('aarch64', target): |
| 26 | grubtarget = 'arm64' |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | elif re.match('arm', target): |
| 28 | grubtarget = 'arm' |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 29 | else: |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target) |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 31 | grubimage = prefix + d.getVar("EFI_BOOT_IMAGE") |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 32 | d.setVar("GRUB_TARGET", grubtarget) |
| 33 | d.setVar("GRUB_IMAGE", grubimage) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 34 | prefix = "grub-efi-" if prefix == "" else "" |
| 35 | d.setVar("GRUB_IMAGE_PREFIX", prefix) |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 36 | } |
| 37 | |
| 38 | inherit deploy |
| 39 | |
| 40 | CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN=" |
| 41 | EXTRA_OECONF += "--enable-efiemu=no" |
| 42 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 43 | do_mkimage() { |
| 44 | cd ${B} |
| 45 | # Search for the grub.cfg on the local boot media by using the |
| 46 | # built in cfg file provided via this recipe |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 47 | grub-mkimage -c ../cfg -p ${EFIDIR} -d ./grub-core/ \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 48 | -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} \ |
| 49 | ${GRUB_BUILDIN} |
| 50 | } |
| 51 | |
| 52 | addtask mkimage before do_install after do_compile |
| 53 | |
Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame^] | 54 | do_install() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 55 | oe_runmake 'DESTDIR=${D}' -C grub-core install |
| 56 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 57 | # Remove build host references... |
| 58 | find "${D}" -name modinfo.sh -type f -exec \ |
| 59 | sed -i \ |
| 60 | -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ |
| 61 | -e 's|${DEBUG_PREFIX_MAP}||g' \ |
| 62 | -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ |
| 63 | {} + |
Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame^] | 64 | |
| 65 | install -d ${D}${EFI_FILES_PATH} |
| 66 | install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${D}${EFI_FILES_PATH}/${GRUB_IMAGE} |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 67 | } |
| 68 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 69 | do_install_append_aarch64() { |
| 70 | rm -rf ${D}/${prefix}/ |
| 71 | } |
| 72 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 73 | GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 74 | efi_gop iso9660 configfile search loadenv test" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 75 | |
| 76 | do_deploy() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 77 | install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${DEPLOYDIR} |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 78 | } |
| 79 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 80 | addtask deploy after do_install before do_build |
| 81 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 82 | FILES_${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \ |
| 83 | ${datadir}/grub \ |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 84 | ${EFI_FILES_PATH}/${GRUB_IMAGE} \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 85 | " |
| 86 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 87 | FILES_${PN}_remove_aarch64 = "${libdir}/grub/${GRUB_TARGET}-efi" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 88 | |
| 89 | # 64-bit binaries are expected for the bootloader with an x32 userland |
| 90 | INSANE_SKIP_${PN}_append_linux-gnux32 = " arch" |
| 91 | INSANE_SKIP_${PN}-dbg_append_linux-gnux32 = " arch" |
| 92 | INSANE_SKIP_${PN}_append_linux-muslx32 = " arch" |
| 93 | INSANE_SKIP_${PN}-dbg_append_linux-muslx32 = " arch" |