blob: 30d95f95e01edcc638da2155ea632b51ab218bc3 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require grub2.inc
2
Brad Bishopa34c0302019-09-23 22:34:48 -04003require conf/image-uefi.conf
4
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005GRUBPLATFORM = "efi"
6
Andrew Geisslerd25ed322020-06-27 00:28:28 -05007DEPENDS_append = " grub-native"
8RDEPENDS_${PN} = "grub-common virtual/grub-bootconf"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
10SRC_URI += " \
11 file://cfg \
12 "
13
14S = "${WORKDIR}/grub-${PV}"
15
16# Determine the target arch for the grub modules
17python __anonymous () {
18 import re
19 target = d.getVar('TARGET_ARCH')
Brad Bishop316dfdd2018-06-25 12:45:53 -040020 prefix = "" if d.getVar('EFI_PROVIDER') == "grub-efi" else "grub-efi-"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021 if target == "x86_64":
22 grubtarget = 'x86_64'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023 elif re.match('i.86', target):
24 grubtarget = 'i386'
Brad Bishop316dfdd2018-06-25 12:45:53 -040025 elif re.match('aarch64', target):
26 grubtarget = 'arm64'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027 elif re.match('arm', target):
28 grubtarget = 'arm'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050029 else:
Brad Bishop316dfdd2018-06-25 12:45:53 -040030 raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target)
Brad Bishopa34c0302019-09-23 22:34:48 -040031 grubimage = prefix + d.getVar("EFI_BOOT_IMAGE")
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032 d.setVar("GRUB_TARGET", grubtarget)
33 d.setVar("GRUB_IMAGE", grubimage)
Brad Bishop316dfdd2018-06-25 12:45:53 -040034 prefix = "grub-efi-" if prefix == "" else ""
35 d.setVar("GRUB_IMAGE_PREFIX", prefix)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050036}
37
38inherit deploy
39
40CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN="
41EXTRA_OECONF += "--enable-efiemu=no"
42
Brad Bishop316dfdd2018-06-25 12:45:53 -040043do_mkimage() {
44 cd ${B}
45 # Search for the grub.cfg on the local boot media by using the
46 # built in cfg file provided via this recipe
Brad Bishopa34c0302019-09-23 22:34:48 -040047 grub-mkimage -c ../cfg -p ${EFIDIR} -d ./grub-core/ \
Brad Bishop316dfdd2018-06-25 12:45:53 -040048 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} \
49 ${GRUB_BUILDIN}
50}
51
52addtask mkimage before do_install after do_compile
53
Andrew Geisslerd25ed322020-06-27 00:28:28 -050054do_install() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040055 oe_runmake 'DESTDIR=${D}' -C grub-core install
56
Brad Bishopd7bf8c12018-02-25 22:55:05 -050057 # Remove build host references...
58 find "${D}" -name modinfo.sh -type f -exec \
59 sed -i \
60 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
61 -e 's|${DEBUG_PREFIX_MAP}||g' \
62 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
63 {} +
Andrew Geisslerd25ed322020-06-27 00:28:28 -050064
65 install -d ${D}${EFI_FILES_PATH}
66 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${D}${EFI_FILES_PATH}/${GRUB_IMAGE}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050067}
68
Brad Bishop08902b02019-08-20 09:16:51 -040069do_install_append_aarch64() {
70 rm -rf ${D}/${prefix}/
71}
72
Brad Bishopd7bf8c12018-02-25 22:55:05 -050073GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal \
Brad Bishop316dfdd2018-06-25 12:45:53 -040074 efi_gop iso9660 configfile search loadenv test"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050075
76do_deploy() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040077 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${DEPLOYDIR}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050078}
79
Brad Bishopd7bf8c12018-02-25 22:55:05 -050080addtask deploy after do_install before do_build
81
Brad Bishop316dfdd2018-06-25 12:45:53 -040082FILES_${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \
83 ${datadir}/grub \
Brad Bishopa34c0302019-09-23 22:34:48 -040084 ${EFI_FILES_PATH}/${GRUB_IMAGE} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040085 "
86
Brad Bishop08902b02019-08-20 09:16:51 -040087FILES_${PN}_remove_aarch64 = "${libdir}/grub/${GRUB_TARGET}-efi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050088
89# 64-bit binaries are expected for the bootloader with an x32 userland
90INSANE_SKIP_${PN}_append_linux-gnux32 = " arch"
91INSANE_SKIP_${PN}-dbg_append_linux-gnux32 = " arch"
92INSANE_SKIP_${PN}_append_linux-muslx32 = " arch"
93INSANE_SKIP_${PN}-dbg_append_linux-muslx32 = " arch"