blob: c8e49ed9930eca3813d68e0ecd87e004652823a2 [file] [log] [blame]
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -06001SUMMARY = "Network DBUS object"
2DESCRIPTION = "Network DBUS object"
3HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
4PR = "r1"
5
Matthew Barth385b5372016-09-28 13:14:43 -05006inherit autotools pkgconfig
Ratan Gupta153a6dc2017-04-28 10:12:54 +05307inherit pythonnative
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -06008inherit obmc-phosphor-license
Brad Bishop3e7c23d2016-09-06 20:37:22 -04009inherit obmc-phosphor-dbus-service
Patrick Williamsab8de5b2017-05-29 22:08:38 -050010inherit phosphor-networkd-rev
vishwa63f0fce2016-06-20 06:41:52 -050011
Brad Bishop3e7c23d2016-09-06 20:37:22 -040012DBUS_SERVICE_${PN} += "org.openbmc.NetworkManager.service"
Ratan Guptad3c61642017-07-06 21:09:14 +053013DBUS_SERVICE_${PN} += "xyz.openbmc_project.Network.service"
14
Brad Bishop3e7c23d2016-09-06 20:37:22 -040015SYSTEMD_SERVICE_${PN} += "network-update-dns.service"
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060016
Matthew Barth0c9d4d22016-10-24 12:51:20 -050017DEPENDS += "systemd"
Matthew Barth385b5372016-09-28 13:14:43 -050018DEPENDS += "autoconf-archive-native"
Ratan Gupta153a6dc2017-04-28 10:12:54 +053019DEPENDS += "sdbusplus sdbusplus-native"
20DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
21DEPENDS += "phosphor-logging"
22
Matthew Barth0c9d4d22016-10-24 12:51:20 -050023RDEPENDS_${PN} += "libsystemd"
Patrick Venture7a2c9d72017-06-15 09:19:58 -070024RDEPENDS_${PN} += "python-dbus python-pygobject python-ipy python-subprocess"
Ratan Gupta153a6dc2017-04-28 10:12:54 +053025RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
26RDEPENDS_${PN} += "phosphor-logging"
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060027
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060028S = "${WORKDIR}/git"
29
Brad Bishop3e7c23d2016-09-06 20:37:22 -040030do_install_append() {
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060031 install -d ${D}/${sbindir}
32 install ${S}/netman.py ${D}/${sbindir}
Ratan Gupta9e376b82016-10-24 22:48:11 -050033 install ${S}/conf/network-manager.conf ${D}/${sysconfdir}
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060034}