blob: 839577326e4dfd37cb0ec2e2ea3e27f254d0879e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
Andrew Geisslerd5838332022-05-27 11:33:10 -050012SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.xz"
Brad Bishop19323692019-04-05 15:28:33 -040013
Andrew Geisslerd5838332022-05-27 11:33:10 -050014SRC_URI[sha256sum] = "cc38744f817cf6814c847e2df37fcb8997357d72fa4bcbc228ae0fe47219a059"
Brad Bishop19323692019-04-05 15:28:33 -040015
16BBCLASSEXTEND = "native nativesdk"
17
18DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
19
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050020PACKAGES_DYNAMIC = "^${PN}-.*"
Brad Bishop19323692019-04-05 15:28:33 -040021
Patrick Williams213cb262021-08-07 19:21:33 -050022FILES:${PN} = "${libdir}/libxcb.so.*"
Brad Bishop19323692019-04-05 15:28:33 -040023
Brad Bishop6dbb3162019-11-25 09:41:34 -050024inherit autotools pkgconfig features_check
Brad Bishop19323692019-04-05 15:28:33 -040025
26# The libxau and others requires x11 in DISTRO_FEATURES
27REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishop19323692019-04-05 15:28:33 -040028
29export PYTHON = "python3"
30
Patrick Williams213cb262021-08-07 19:21:33 -050031do_install:append () {
Andrew Geissler6ce62a22020-11-30 19:58:47 -060032 chown root.root ${D}${datadir}/doc/${BPN}/tutorial -R
33}
34
Patrick Williams213cb262021-08-07 19:21:33 -050035python populate_packages:prepend () {
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050036 do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', '${PN}-%s', 'XCB library module for %s', allow_links=True)
Brad Bishop19323692019-04-05 15:28:33 -040037}